Open Bug 659178 Opened 11 years ago Updated 8 years ago

Using channel switcher to switch to release channel does nothing

Categories

(Firefox :: General, defect)

5 Branch
x86
macOS
defect
Not set
normal

Tracking

()

Tracking Status
firefox5 - ---

People

(Reporter: cww, Unassigned)

Details

(Whiteboard: [channel-switcher])

Right now, on Firefox 5, if you use the channel switcher to switch back to the release channel, it doesn't actually work and users can't switch back and forth between release and beta as expected.
Adding feedback items from input to tracking so we can make sure that they don't get missed.
Whiteboard: [channel-switcher]
Cww: making sure you know for support purposes that until we actually release Firefox 5, switching to the release channel isn't expected to work immediately. We've only populated Beta and Aurora channels so far.

What it does do is set a flag that will cause Firefox to update you as soon as the release is ready, so you can perform the switch then.
The problem is that the feature is being billed as a way to just try out Firefox 5/6 with an escape hatch of moving to release.  People expect Firefox 4 and it's a common complaint because the feature feels broken.
This feature is going away. This bug will be resolved as Wontfix, I presume.
You need to log in before you can comment on or make changes to this bug.