Last Comment Bug 659207 - --enable-shared-js builds are broken
: --enable-shared-js builds are broken
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla6
Assigned To: Boris Zbarsky [:bz] (Out June 25-July 6)
:
Mentors:
Depends on:
Blocks: 650273
  Show dependency treegraph
 
Reported: 2011-05-23 18:44 PDT by Boris Zbarsky [:bz] (Out June 25-July 6)
Modified: 2011-06-05 17:09 PDT (History)
6 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected


Attachments
Don't inline a constructor that consumers can't actually inline without statically linking to JS. (1.25 KB, patch)
2011-05-23 18:46 PDT, Boris Zbarsky [:bz] (Out June 25-July 6)
mrbkap: review+
christian: approval‑mozilla‑beta-
Details | Diff | Review

Description Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-23 18:44:54 PDT
Actually, any build that tries to use js::ForceFrame without statically linking JS, because the destructor is inline but uses non-exported stuff.

This broke all my builds, for example.  :(
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-23 18:46:40 PDT
Created attachment 534648 [details] [diff] [review]
Don't inline a constructor that consumers can't actually inline without statically linking to JS.
Comment 2 Blake Kaplan (:mrbkap) (in and out until 7-14) 2011-05-24 08:13:50 PDT
Comment on attachment 534648 [details] [diff] [review]
Don't inline a constructor that consumers can't actually inline without statically linking to JS.

It makes me sad that this is necessary.
Comment 3 Mounir Lamouri (:mounir) 2011-05-24 08:49:07 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/837f762860af
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-05-25 11:53:09 PDT
No need to track: release drivers are conflicted on whether we'd take a patch which doesn't affect our release builds on the beta channel...
Comment 5 Blake Kaplan (:mrbkap) (in and out until 7-14) 2011-05-26 11:32:08 PDT
Comment on attachment 534648 [details] [diff] [review]
Don't inline a constructor that consumers can't actually inline without statically linking to JS.

I think we should take this for beta.
Comment 6 christian 2011-06-03 15:17:31 PDT
This doesn't apply cleanly to mozilla-beta. Rescinding approval as we are late in beta anyway.
Comment 7 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-05 17:09:17 PDT
Um... Making this apply cleanly is a trivial merge, which I was going to do on Monday.

Either way, though.  I guess it doesn't matter that much if our beta and fx5 can't be built in some supported configurations....

Note You need to log in before you can comment on or make changes to this bug.