Last Comment Bug 659263 - move content/xul/*.xul tests from mochitest-plain to mochitest-chrome
: move content/xul/*.xul tests from mochitest-plain to mochitest-chrome
Status: RESOLVED FIXED
[specialpowers]
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Joel Maher ( :jmaher)
:
:
Mentors:
Depends on:
Blocks: 462483
  Show dependency treegraph
 
Reported: 2011-05-24 04:07 PDT by Joel Maher ( :jmaher)
Modified: 2011-06-09 10:31 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
move content/xul/*.xul tests to mochitest-chrome (1.0) (22.71 KB, patch)
2011-05-24 04:13 PDT, Joel Maher ( :jmaher)
bzbarsky: review+
bugs: review+
ted: feedback+
Details | Diff | Splinter Review

Description Joel Maher ( :jmaher) 2011-05-24 04:07:14 PDT
with special powers and the push to remove universalxpconnect, it is a good time to revisit our tests and try to move mochitests that use a lot of XUL to run in the mochitest-chrome harness
Comment 1 Joel Maher ( :jmaher) 2011-05-24 04:13:24 PDT
Created attachment 534718 [details] [diff] [review]
move content/xul/*.xul tests to mochitest-chrome (1.0)

this patch moves these tests to mochitest-chrome:
/content/xul/content/test/test_bug233643.xul
/content/xul/content/test/test_bug330705-2.xul
/content/xul/document/test/test_bug199692.xul
/content/xul/document/test/test_bug311681.xul
/content/xul/document/test/test_bug335375.xul
/content/xul/document/test/test_bug391002.xul
/content/xul/document/test/test_bug403868.xul
/content/xul/document/test/test_bug414907.xul
/content/xul/document/test/test_bug418216.xul
/content/xul/document/test/test_bug445177.xul
/content/xul/document/test/test_bug449457.xul
/content/xul/document/test/test_bug468176.xul
/content/xul/templates/tests/chrome/bug441785-1.rdf
/content/xul/templates/tests/chrome/bug441785-2.rdf
/content/xul/templates/tests/chrome/test_bug441785.xul
/content/xul/templates/tests/chrome/test_sortservice.xul

I would like to make sure that these tests will be getting the intended coverage before moving the tests.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-05-24 08:00:13 PDT
It'd really work better to ask the test authors...  I'll see if I can make time for this, but I'd have to go through and read the tests and bugs carefully to figure out what all is going on....
Comment 3 Joel Maher ( :jmaher) 2011-05-24 09:32:13 PDT
:bz, can you verify these tests will be fine in mochitest-chrome:
/content/xul/document/test/test_bug311681.xul
/content/xul/document/test/test_bug403868.xul
/content/xul/templates/tests/chrome/test_bug441785.xul

:smaug, can you verify these tests:
/content/xul/document/test/test_bug445177.xul
/content/xul/document/test/test_bug449457.xul
/content/xul/document/test/test_bug468176.xul

:waldo, can you verify this test:
/content/xul/document/test/test_bug199692.xul

:arno, can you verify these tests:
/content/xul/document/test/test_bug391002.xul
/content/xul/document/test/test_bug414907.xul
/content/xul/document/test/test_bug418216.xul

ehsan, can you verify this test:
/content/xul/content/test/test_bug233643.xul

ian, can you verify this test:
/content/xul/content/test/test_bug330705-2.xul

neal, cna you verify this test:
/content/xul/templates/tests/chrome/test_sortservice.xul
Comment 4 Ian Neal 2011-05-24 10:07:04 PDT
cc'ing right people for:
/content/xul/content/test/test_bug330705-2.xul
/content/xul/templates/tests/chrome/test_sortservice.xul
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-05-24 11:17:04 PDT
Comment on attachment 534718 [details] [diff] [review]
move content/xul/*.xul tests to mochitest-chrome (1.0)

Review of attachment 534718 [details] [diff] [review]:
-----------------------------------------------------------------

The mechanics look fine to me, needs signoff from subject matter experts, obviously.

::: content/xul/content/test/Makefile.in
@@ +54,3 @@
>   		test_bug398289.html \
>   		398289-resource.xul \
>   		$(NULL)

Can you change the indentation from a tab to two spaces while you're here?
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2011-05-24 13:05:19 PDT
Comment on attachment 534718 [details] [diff] [review]
move content/xul/*.xul tests to mochitest-chrome (1.0)

> :bz, can you verify these tests will be fine in mochitest-chrome:

Looks ok to me.
Comment 7 Joel Maher ( :jmaher) 2011-06-09 10:31:25 PDT
http://hg.mozilla.org/mozilla-central/rev/38f213874df7

Note You need to log in before you can comment on or make changes to this bug.