Last Comment Bug 659266 - Need a minimalistic Sync glyph for notifications
: Need a minimalistic Sync glyph for notifications
Status: VERIFIED FIXED
[inbound]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 7
Assigned To: Stephen Horlander [:shorlander]
:
Mentors:
Depends on:
Blocks: 618913
  Show dependency treegraph
 
Reported: 2011-05-24 04:23 PDT by Marco Bonardo [::mak]
Modified: 2011-07-14 05:16 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed


Attachments
Sync Glyph for the Panel Notification - 01 (7.27 KB, patch)
2011-06-30 11:45 PDT, Stephen Horlander [:shorlander]
no flags Details | Diff | Review
Screenshot - 01 (122.26 KB, image/png)
2011-06-30 11:45 PDT, Stephen Horlander [:shorlander]
no flags Details
Sync Glyph for the Panel Notification - 02 (8.97 KB, patch)
2011-06-30 14:15 PDT, Stephen Horlander [:shorlander]
dolske: review+
Details | Diff | Review
Sync Glyph for the Panel Notification - 03 (8.42 KB, patch)
2011-07-04 07:05 PDT, Marco Bonardo [::mak]
asa: approval‑mozilla‑beta+
Details | Diff | Review

Description Marco Bonardo [::mak] 2011-05-24 04:23:35 PDT
bug 618913 landed with a 24px Sync icon, but UX would prefer a more minimalistic icon for it, replacing the icon is trivial, so it may land on central and Aurora.
Tentatively assigning to Stephen.
Comment 1 Stephen Horlander [:shorlander] 2011-06-30 11:45:06 PDT
Created attachment 543204 [details] [diff] [review]
Sync Glyph for the Panel Notification - 01

Adds low key images for the Sync notification.
Comment 2 Stephen Horlander [:shorlander] 2011-06-30 11:45:53 PDT
Created attachment 543205 [details]
Screenshot - 01
Comment 3 Marco Bonardo [::mak] 2011-06-30 12:03:17 PDT
it's really nice.
A couple questions:
1. Is it expected that on gnomestripe we keep the current sync-24.png?
2. Why didn't you remove sync-24.png from pinstripe and winstripe? Should be unused now.
Comment 4 Stephen Horlander [:shorlander] 2011-06-30 12:12:05 PDT
(In reply to comment #3)
> it's really nice.
> A couple questions:
> 1. Is it expected that on gnomestripe we keep the current sync-24.png?

Yes. It will work better than trying to match variable themes.

> 2. Why didn't you remove sync-24.png from pinstripe and winstripe? Should be
> unused now.

Oh yeah, I should do that :) Forgot we added that just for this.
Comment 5 Stephen Horlander [:shorlander] 2011-06-30 14:15:35 PDT
Created attachment 543254 [details] [diff] [review]
Sync Glyph for the Panel Notification - 02

Removed the unused sync-24.png
Comment 6 Marco Bonardo [::mak] 2011-07-01 14:29:52 PDT
I think, for consistency, may make sense to rename the gnomestripe sync-24.png to sync-notification-24.png it may be confusing for future otherwise.
Sorry if I didn't point this out before.
Comment 7 Marco Bonardo [::mak] 2011-07-04 07:05:42 PDT
Created attachment 543767 [details] [diff] [review]
Sync Glyph for the Panel Notification - 03

I've renamed the icon in gnomestripe, for previous comment, moved in jar.mn according to the other themes.
Comment 9 Marco Bonardo [::mak] 2011-07-04 11:43:45 PDT
http://hg.mozilla.org/mozilla-central/rev/8460bb7fb589
Comment 10 Marco Bonardo [::mak] 2011-07-07 03:57:10 PDT
Comment on attachment 543767 [details] [diff] [review]
Sync Glyph for the Panel Notification - 03

May we get beta approval on this icon replacement?
I think the first impact of this notification is important, and we'll have that impact in Firefox 7. This change is a try to make the notification less intrusive to the user, since it's not intended to be annoying nor look like an advertisement.
Comment 11 Marco Bonardo [::mak] 2011-07-07 03:58:28 PDT
ehr, in comment 5 I meant "we'll have that impact in Firefox 6"
Comment 12 Asa Dotzler [:asa] 2011-07-11 14:21:00 PDT
Comment on attachment 543767 [details] [diff] [review]
Sync Glyph for the Panel Notification - 03

approval for beta. did this make aurora?
Comment 13 Marco Bonardo [::mak] 2011-07-11 14:49:37 PDT
sure, it made Aurora.
Comment 14 Marco Bonardo [::mak] 2011-07-12 15:58:59 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/6e78e6a73460
Comment 15 AndreiD[QA] 2011-07-14 05:16:57 PDT
Verified on 6.0 Beta, build 2:
Mac: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:6.0) Gecko/20100101 Firefox/6.0
Windows 7: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0
Windows XP: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Linux: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0

Notifications to set up sync are visible (when bookmarking a website a message that promotes Sync is visible to the user)

Note You need to log in before you can comment on or make changes to this bug.