Closed Bug 659283 Opened 10 years ago Closed 6 years ago

Reflect.parse("let a") gives kind: "var"

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 589199

People

(Reporter: zbraniecki, Unassigned)

Details

(Whiteboard: reflect-parse)

steps to reproduce:

1) obj = Reflect.parse("let a");
2) (obj.body[0]['kind']=="let") returns false
Whiteboard: reflect-parse
I think there may not be anything we can do about this for now. Right now, a top-level |let| is treated by SpiderMonkey as a |var|. This may not remain the case in the future, when we work out the semantics of |let| in Harmony, but TC39 hasn't worked it out yet.

Dave
Assignee: general → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589199
You need to log in before you can comment on or make changes to this bug.