Last Comment Bug 659295 - Expose the current document to GCLI commands so they can return DOM elements
: Expose the current document to GCLI commands so they can return DOM elements
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: GCLI-HELP
  Show dependency treegraph
 
Reported: 2011-05-24 06:36 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-06-21 02:50 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-05-24 06:36:42 PDT
Use of the global document can't be assumed in Firefox, so commands will be unable to create nodes.

For example:

var doc = gcli.getDocument();
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-21 02:50:46 PDT
Marking verified because there is no UI proof that the bug is fixed. The proof is in the code.

Note You need to log in before you can comment on or make changes to this bug.