Last Comment Bug 659405 - content page bleeds through Desktop Tab view
: content page bleeds through Desktop Tab view
Status: VERIFIED FIXED
: verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 6
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
: 659635 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 12:01 PDT by Tony Chung [:tchung]
Modified: 2011-06-13 17:07 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Desktop Tab screenshot (75.88 KB, image/png)
2011-05-24 12:01 PDT, Tony Chung [:tchung]
no flags Details
Honeycomb theme desktop tab screenshot (38.79 KB, image/png)
2011-05-24 13:19 PDT, Tony Chung [:tchung]
no flags Details
patch (1.50 KB, patch)
2011-05-24 21:38 PDT, Mark Finkle (:mfinkle) (use needinfo?)
21: review+
dougt: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Tony Chung [:tchung] 2011-05-24 12:01:16 PDT
Created attachment 534855 [details]
Desktop Tab screenshot

On the nightly that Gingerbread theme landed, the Desktop View seems to pass through the content page in the background, instead of loading Sync'd tabs. 

See screenshot

Repro:
1) install android nightly (must have gingerbread OS device--HTC Flyer, 2.3.3): Mozilla/5.0 (Android; Linux armv71; rv:6.0a1) Gecko/20110524 Firefox/6.0a1 Fennec/6.0a1
2) setup sync and connect
3) launch awesomescreen, click Desktop Tab
4) Verify the previous content page will bleed through the Desktop Tab view  (throbber included!)

Expected;
- sync'd tab view 

Actual:
- content page instead
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-24 12:24:41 PDT
Tony, is this a gingerbread only issue? Can you try it on a Android 2.2 (or less) phone?
Comment 2 Tony Chung [:tchung] 2011-05-24 13:13:26 PDT
I've repro'd this on 2.3.3, 2.3.4, and 3.1 (xoom-Old Theme)
Comment 3 Tony Chung [:tchung] 2011-05-24 13:14:09 PDT
Flagging for blocking fennec 6
Comment 4 Tony Chung [:tchung] 2011-05-24 13:19:39 PDT
Created attachment 534870 [details]
Honeycomb theme desktop tab screenshot

screenshot for Xoom, running Android 3.1 (old theme)
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-24 21:38:30 PDT
Created attachment 534981 [details] [diff] [review]
patch

the browser.css is out of sync and missing some new rules for the awesomebar binding. This likely happened because the two patches landed too closely to each other.

Hopefully, we have an easier time catching these problems.
Comment 6 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-25 03:19:38 PDT
Comment on attachment 534981 [details] [diff] [review]
patch

Stealing the r? since I know this code for having wrote it :)
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 06:46:01 PDT
pushed:
http://hg.mozilla.org/mozilla-central/rev/32b009addadd
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 06:46:43 PDT
Comment on attachment 534981 [details] [diff] [review]
patch

Needed for Fx6. The theme bustage is in aurora too.
Comment 9 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-05-25 07:54:40 PDT
*** Bug 659635 has been marked as a duplicate of this bug. ***
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 11:52:16 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/873ad7961640
Comment 11 Tony Chung [:tchung] 2011-06-13 17:07:14 PDT
Verified fix on 6/13 trunk and 6/13 aurora

Note You need to log in before you can comment on or make changes to this bug.