Closed Bug 659670 Opened 9 years ago Closed 9 years ago

Add quit fennec into the browser

Categories

(Firefox for Android Graveyard :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 7

People

(Reporter: aakashd, Assigned: mbrubeck)

References

Details

Attachments

(1 file, 1 obsolete file)

There are a number of users that ask for an exit button in Fennec:

https://input.mozilla.com/en-US/search?product=mobile&version=--&date_start=&date_end=&q=exit


We have a super cool extension that does it, but I think it poses a general enough use case (i.e. people want to close apps that take up a lot of memory and cpu without having to go to the task manager) to add into the browser.
Also please note that running Beta, Nightly and the Aurora build may lead to the OOM issues.
Attached patch patch (obsolete) — Splinter Review
This patch adds a "Quit" item to the app menu.  It's the last item in the menu, so it appears in the overflow ("More") section of the menu.  If there are multiple tabs open, Fennec will prompt before closing them by default (just as it does when you close the window on Maemo).

I've been against this for a while since it *shouldn't* be necessary on Android, but I think there are enough use cases to justify it, and it is a very simple change both to the UI and the code.

In particular, this helps with the issue where people never see the home page because there's no way to get out of the previous session (except to wait until the system kills the browser and then wait at least 60 minutes past that).
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #539841 - Flags: ui-review?(madhava)
Attachment #539841 - Flags: review?(mark.finkle)
Blocks: 664369
Whiteboard: [has patch]
Attached patch patch v2Splinter Review
Fix a typo in the previous patch.
Attachment #539841 - Attachment is obsolete: true
Attachment #539841 - Flags: ui-review?(madhava)
Attachment #539841 - Flags: review?(mark.finkle)
Attachment #539846 - Flags: ui-review?(madhava)
Attachment #539846 - Flags: review?(mark.finkle)
Duplicate of this bug: 657898
I'm still not a big fan of this, both from a "shouldn't be necessary" perspective (like the one Matt mentioned) and a general UI minimalism perspective. On the one hand, we have a menu now where it can sit, mostly unnoticed and out of the way; on the other hand, this is how massive obscure menus start.
Meant to close that last comment with "still thinking about this."
All programs that have the potential to use excessive memory have a quit/exit feature. The general assumption here is that people are using one or two tabs at a time and that all pages are coded efficiently. Not to mention that with this, we can actually start to introduce proper session management. UI minimalism should never take precedent over usability, not to mention that this can be buried successfully under the more menu of App Menu thus negating worries of UI minimalism.
Comment on attachment 539846 [details] [diff] [review]
patch v2

window.close() will end up calling Browser.closing() so this looks good.

Let's move on to hammer out the UI details
Attachment #539846 - Flags: review?(mark.finkle) → review+
OK. I'm philosophically against this, but, in practical terms, I don't object. The real goal would be to reduce memory usage, but that's a longer-term goal.
Attachment #539846 - Flags: ui-review?(madhava)
Pushed:
http://hg.mozilla.org/mozilla-central/rev/7dace7386901
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 7
VERIFIED FIXED on:

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110620 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.