Last Comment Bug 659728 - Android app menu layout broken in Gingerbread theme with >4 items
: Android app menu layout broken in Gingerbread theme with >4 items
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: Extension Compatibility (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 6
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks: 653134
  Show dependency treegraph
 
Reported: 2011-05-25 12:30 PDT by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2011-06-23 14:58 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (64.86 KB, image/png)
2011-05-25 12:30 PDT, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
4 items (53.29 KB, image/png)
2011-05-25 12:54 PDT, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
Fennec 5b2 (58.70 KB, image/png)
2011-05-25 13:24 PDT, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
App menu icons - 42x42 (6.66 KB, application/zip)
2011-05-25 14:18 PDT, Ian Barlow (:ibarlow)
no flags Details
patch (6.84 KB, patch)
2011-05-25 14:22 PDT, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-25 12:30:13 PDT
Created attachment 535147 [details]
Screenshot

Mozilla/5.0 (Android; Linux armv71; rv7.0a1) Gecko/20110525 Firefox/7.0a1 Fennec/7.0a1
Device: HTC Flyer
OS: Android 2.2

1. Hit the menu option for the on the Flyer after loading Fennec

Expected: Squares are even and the wording is readable on the bottom row
Actual: the lettering is off and there's no symmetry; See Screenshot
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 12:46:08 PDT
(In reply to comment #0)

> Fennec/7.0a1
> Device: HTC Flyer
> OS: Android 2.2

Android 2.2? The Gingerbread Theme should be for 2.3 or higher

> 1. Hit the menu option for the on the Flyer after loading Fennec
> 
> Expected: Squares are even and the wording is readable on the bottom row
> Actual: the lettering is off and there's no symmetry; See Screenshot

* I see "Quit Firefox" is installed. Can you uninstall and try again?
* Can you test on Firefox 5 Beta 2 and see if the old theme has the same problem?
Comment 2 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-25 12:54:32 PDT
Created attachment 535157 [details]
4 items

I disabled quit and itis more legible.  The spacing is a bit tight.  see new attachment
Comment 3 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-25 13:24:41 PDT
Created attachment 535167 [details]
Fennec 5b2

Fennec 5b2 seems to be ok.  See screenshot.
Comment 4 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-25 13:28:03 PDT
Forgot to mention, I had the wrong text for the OS version: should be OS: 2.3
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 13:32:16 PDT
(In reply to comment #3)
> Created attachment 535167 [details]
> Fennec 5b2
> 
> Fennec 5b2 seems to be ok.  See screenshot.

Based on this, I am assuming the image size change in the app menu icons is to blame. The old theme used 42px images and the new gingerbread theme uses 48px images.

We could always use 42px images (making it a bit easier for add-ons) or we could update the sizing in the menu to better accommodate the larger size.

If we keep the larger size and an add-on doesn't support both sizes, it would potentially create an unbalanced look.
Comment 6 Matt Brubeck (:mbrubeck) 2011-05-25 14:04:47 PDT
(In reply to comment #5)
> If we keep the larger size and an add-on doesn't support both sizes, it
> would potentially create an unbalanced look.

If we do keep the larger size for Gingerbread, we can add padding to the Froyo image files so that the PNGs are the same size even if the icons aren't.  Then add-ons can provide a single PNG that will at least keep the same layout with either skin.

(It would still be difficult for add-ons to actually look consistent with both skins -- for add-on compatibility, it would be best to just use the old icon size in both.)
Comment 7 Ian Barlow (:ibarlow) 2011-05-25 14:06:25 PDT
mbrubeck: For the sake of visual consistency (and simplicity), let's go back to using icons at the old size (42x42). I'm making new ones and will post them shortly.
Comment 8 Ian Barlow (:ibarlow) 2011-05-25 14:18:23 PDT
Created attachment 535182 [details]
App menu icons - 42x42

Updated icons attached :)
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 14:22:05 PDT
Created attachment 535184 [details] [diff] [review]
patch

Simple replacement patch
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-26 07:20:42 PDT
http://hg.mozilla.org/mozilla-central/rev/b19dbdf3c45e
Comment 11 Matt Brubeck (:mbrubeck) 2011-05-26 11:54:36 PDT
This still needs approval to land in Aurora for Firefox 6; it is a regression compared to Firefox 5 and affects several add-ons, including one of our most popular featured add-ons.
Comment 12 Matt Brubeck (:mbrubeck) 2011-05-27 07:24:05 PDT
Pushed to Aurora for Firefox 6: http://hg.mozilla.org/releases/mozilla-aurora/rev/f5ab57ebf2da
Comment 13 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-05-27 10:24:23 PDT
Verified for Nightly :
Mozilla/5.0 (Android; Linux armv71; rv7.0a1) Gecko/20110527 Firefox/7.0a1 Fennec/7.0a1
Device: HTC Flyer
OS: Android 2.3
Comment 14 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-06-23 13:42:39 PDT
Mozilla/5.0 (Android; Linux armv71; rv6.0a2) Gecko/20110623 Firefox/6.0a2 Fennec/6.0a2
Device: HTC Flyer
OS: Android 2.3

Note You need to log in before you can comment on or make changes to this bug.