Last Comment Bug 659763 - document.open("text/plain") broken with HTML5 parser
: document.open("text/plain") broken with HTML5 parser
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla10
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
:
:
Mentors:
http://software.hixie.ch/utilities/js...
Depends on: 479959
Blocks: html5-parsing
  Show dependency treegraph
 
Reported: 2011-05-25 14:13 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-11-02 06:36 PDT (History)
7 users (show)
hsivonen: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Support text/plain with document.open (2.93 KB, patch)
2011-05-31 07:21 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
no flags Details | Diff | Splinter Review
Reftests (4.62 KB, patch)
2011-06-01 05:01 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
no flags Details | Diff | Splinter Review
Reftest, with one more test (5.38 KB, patch)
2011-06-01 05:04 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
bzbarsky: review+
Details | Diff | Splinter Review
Support text/plain with document.open, rebased (2.75 KB, patch)
2011-10-14 07:57 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
bugs: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-05-25 14:13:51 PDT
And apparently, nobody noticed. Not sure if we want to fix at this point?
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-05-25 18:19:19 PDT
I think we do need to fix this, yes.  At least as of a few years ago, this feature was still used in various cases...

How did the html5 parser manage to break this?  :(
Comment 3 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-31 07:21:38 PDT
Created attachment 536290 [details] [diff] [review]
Support text/plain with document.open

(In reply to comment #0)
> And apparently, nobody noticed. Not sure if we want to fix at this point?

Chrome doesn't support this, either, but since Opera and IE do, let's fix this.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-05-31 08:59:23 PDT
Can we add a test too?
Comment 5 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-06-01 05:01:50 PDT
Created attachment 536571 [details] [diff] [review]
Reftests

(In reply to comment #4)
> Can we add a test too?

Yeah, just ran out of time yesterday.
Comment 6 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-06-01 05:04:52 PDT
Created attachment 536572 [details] [diff] [review]
Reftest, with one more test
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2011-06-02 05:11:03 PDT
Comment on attachment 536572 [details] [diff] [review]
Reftest, with one more test

r=me
Comment 8 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-10-14 07:57:04 PDT
Created attachment 567088 [details] [diff] [review]
Support text/plain with document.open, rebased
Comment 9 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-01 08:38:35 PDT
Thanks for the reviews. Landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f09b3ca76707
https://hg.mozilla.org/integration/mozilla-inbound/rev/804eb7a2a0c7

Note You need to log in before you can comment on or make changes to this bug.