Last Comment Bug 659768 - HTML5 video does not render anything on Maemo
: HTML5 video does not render anything on Maemo
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM MeeGo
: -- normal (vote)
: mozilla7
Assigned To: Oleg Romashin (:romaxa)
:
:
Mentors:
Depends on:
Blocks: 649417
  Show dependency treegraph
 
Reported: 2011-05-25 14:40 PDT by Oleg Romashin (:romaxa)
Modified: 2011-05-31 07:32 PDT (History)
2 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use mediump presicion for YUV conversion shader (819 bytes, patch)
2011-05-29 17:45 PDT, Oleg Romashin (:romaxa)
matt.woodrow: review+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2011-05-25 14:40:39 PDT
Have not tested it on android with HW acceleration enabled, but on maemo I see only white placeholder after bug 649417 landed
Comment 1 Oleg Romashin (:romaxa) 2011-05-29 17:45:37 PDT
Created attachment 535971 [details] [diff] [review]
Use mediump presicion for YUV conversion shader

On desktop precision is highp by default, and for GL_ES we make it lowp due to perf reasons.
but for YUV layer we should make it mediump
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-30 14:55:09 PDT
http://hg.mozilla.org/projects/cedar/rev/2c64357fcbf3
Comment 3 Mounir Lamouri (:mounir) 2011-05-31 07:32:19 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/2c64357fcbf3

Note You need to log in before you can comment on or make changes to this bug.