Web Console autocomplete is behind the Web Console window

VERIFIED FIXED

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: past)

Tracking

({regression})

Trunk
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox6+ fixed)

Details

(Whiteboard: [fixed-in-devtools])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 535201 [details]
screenshot

1. Open the Web Console (Cmd+Shift+K)
2. In the Web Console's "Position" menu, select "Window".
3. Type 'a', causing an autocomplete menu to appear.

Result: Web Console is on top of the autocomplete menu, so part of the autocomplete menu is not visible.

Comment 1

6 years ago
Probably Mac-only. Not affecting Linux, I'll check my windows build asap.

Updated

6 years ago
Component: Developer Tools → Widget: Cocoa
Product: Firefox → Core
QA Contact: developer.tools → cocoa

Comment 2

6 years ago
I filed it here, but am not sure if Core:Widgets:Cocoa is the correct place for this bug

Comment 3

6 years ago
You should be able to work around it by using level="top" on the autocomplete popup. That should be sufficient as the autocomplete popup itself contains no text entry fields.

Comment 4

6 years ago
Panos is going to give Neil's suggestion a shot.

Adding tracking-firefox6 because this behavior is ugly on Macs and makes autocompletion potentially less usable than it was in Firefox 5.
Assignee: nobody → past
Status: NEW → ASSIGNED
tracking-firefox6: --- → ?

Comment 5

6 years ago
Tracking for Firefox 6.
tracking-firefox6: ? → +
Keywords: regression
Created attachment 540008 [details] [diff] [review]
[in-devtools] Simple fix

The workaround works as advertised.
Attachment #540008 - Flags: review?(ddahl)
Asking ddahl for review since IIRC he has the setup to verify the fix on Macs and make sure there are no regressions on Windows & Linux.

Comment 8

6 years ago
Comment on attachment 540008 [details] [diff] [review]
[in-devtools] Simple fix

Have you tested this with level = floating? "top" may not be the best solution as it will float above any window in any app.

You may consider fixing this as a Mac-specific fix as well.

In case you haven't seen it...
https://developer.mozilla.org/en/XUL/panel#a-panel.level

Comment 9

6 years ago
Other autocomplete panels use level="top". Since the panel should disappear when another application is made active, whether it appears on top of other applications isn't important.

Updated

6 years ago
Attachment #540008 - Flags: review?(ddahl) → review+
Comment on attachment 540008 [details] [diff] [review]
[in-devtools] Simple fix

Thanks for the review Dave! Is everything OK here Neil?
Attachment #540008 - Flags: review?(enndeakin)

Updated

6 years ago
Attachment #540008 - Flags: review?(enndeakin) → review+
Whiteboard: [land-in-devtools]
Comment on attachment 540008 [details] [diff] [review]
[in-devtools] Simple fix

This is slated tracking-firefox-6 so we'd like to approval to land on aurora.
Attachment #540008 - Flags: approval-mozilla-aurora?
still waiting on approval to land this on aurora.

landing in devtools for now.
Whiteboard: [land-in-devtools] → [fixed-in-devtools]
Attachment #540008 - Attachment description: Simple fix → [in-devtools] Simple fix

Comment 13

6 years ago
Comment on attachment 540008 [details] [diff] [review]
[in-devtools] Simple fix

please land on central first. with that you have approval for aurora.
Attachment #540008 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
landed here:

http://hg.mozilla.org/mozilla-central/rev/91aa42463755

and here:

http://hg.mozilla.org/releases/mozilla-aurora/rev/3daeb0cc907a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox6: --- → fixed
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0 beta 5
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a2) Gecko/20110810 Firefox/7.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110811 Firefox/8.0a1

Verified on Mac OS X 10.6. The issue can no longer be reproduced with the steps given in the description. The Web console does no longer overlap part of the autocomplete menu.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.