Closed Bug 65980 Opened 23 years ago Closed 15 years ago

When in history sidebar, show URL in status bar

Categories

(Core Graveyard :: History: Global, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 239429
mozilla1.2alpha

People

(Reporter: st.n, Unassigned)

References

Details

Nice to have the history sidebar now!

One suggestion: when the mouse if over an entry there, can you show me the URL
of that link in the status bar, like when moving the mouse over a link in the
browser?  That would be helpful!

Maybe the normal history window could do this, too, although it's not so
important there, because there is more room to show the URLs in the table.
-> alec
Assignee: radha → alecf
Summary: RfE: when in history sidebar, show URL in status bar → [RFE] When in history sidebar, show URL in status bar
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → mozilla1.0
Component: History: Session → History: Global
I think tooltips would be more appropriate, since the items in history don't 
act like links (you have to double-click them to open them).  See also bug 
32157. which I'm attempting to morph into "cropped tree items should get 
tooltips onmouseover".
Unfortunately they don't act like links. IMHO it would be much better if they
would, at least in the sidebar. I don't like double clicks, for several reasons.
(E.g. I get the clicking speed wrong too often.)

That said, I still would prefer the status bar.
Since I don't need to edit my history list very often, it could make sense to 
make the history sidebar items links.  That would make it a pain to delete 
multiple items, though (but only from the sidebar).

Another problem with using the status bar: we /do/ need tooltips if we're going 
to continue allowing showing columns other than the URL, simply because the 
columns are so narrow.  For consistency, we'd need to also show tooltips for 
the URL, and then we'd be showing the URL in two places on mouseover.
Depends on: 66905
this is not the place to design features - please take the design discussion up
on a newsgroup, and bring the decision back to this bug.
nav triage team:

Not a mozilla1.0 stopper, pushing out to mozilla1.2. Besides, don't we want a
tooltip for the url instead? ;-)
Target Milestone: mozilla1.0 → mozilla1.2
argh.. take two at reassigning history bugs to new owner
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: mozilla1.2 → ---
Target Milestone: --- → mozilla1.0
Target Milestone: mozilla1.0 → mozilla1.2
Summary: [RFE] When in history sidebar, show URL in status bar → When in history sidebar, show URL in status bar
Assignee: bross2 → nobody
QA Contact: claudius → history.global
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.