Last Comment Bug 659944 - Remove leftover MOZ_IPC ifdef in nsHttpChannel.cpp
: Remove leftover MOZ_IPC ifdef in nsHttpChannel.cpp
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on: 639754
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 08:27 PDT by Ed Morley [:emorley]
Modified: 2011-06-11 01:21 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove dead code (1.07 KB, patch)
2011-05-26 10:17 PDT, Ed Morley [:emorley]
cbiesinger: review+
Details | Diff | Review
Remove dead code (1.10 KB, patch)
2011-06-09 17:13 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2011-05-26 08:27:32 PDT
http://mxr.mozilla.org/mozilla-central/source/netwerk/protocol/http/nsHttpChannel.cpp#48

> 48 #ifdef MOZ_IPC
> 49 #include "base/basictypes.h"
> 50 #endif 

MOZ_IPC is no longer defined as of bug 639754, so basictypes.h is no longer included even though it used to be. Since nothing broke shall I just remove it? Or should I remove just the ifdef, thereby restoring the include?
Comment 1 Ed Morley [:emorley] 2011-05-26 10:17:49 PDT
Created attachment 535385 [details] [diff] [review]
Remove dead code

Three line change.

Thanks :-)
Comment 2 Ed Morley [:emorley] 2011-05-26 10:19:09 PDT
Meant to add: I decided to go with the 'just remove it' approach. Please let me know if the alternative is desired instead.
Comment 3 Ed Morley [:emorley] 2011-05-26 13:40:54 PDT
Not exactly a risky patch, but seeing as I was pushing to try anyway...
http://dev.philringnalda.com/tbpl/?tree=Try&rev=814ab5d45c97
Comment 4 Ed Morley [:emorley] 2011-06-09 17:13:39 PDT
Created attachment 538388 [details] [diff] [review]
Remove dead code

Only change is adding the patch author field, which hg missed off despite my hgrc. Carrying forwards r+.

Has passed try (comment 3); author & commit message filled out.
Thanks to whomever checks it in :-)
Comment 5 Dão Gottwald [:dao] 2011-06-11 01:21:50 PDT
http://hg.mozilla.org/mozilla-central/rev/29f87a9792ec

Note You need to log in before you can comment on or make changes to this bug.