TI: correctness bug with x && arguments

RESOLVED FIXED

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jandem, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
--
(function() { "length" in (true && arguments); })()
--
With -n -a this throws:
typein:1: TypeError: invalid 'in' operand undefined

Revision 1252c464553e, 32-bit OS X.
(Reporter)

Updated

7 years ago
Summary: TI+JM: correctness bug with x && arguments → TI: correctness bug with x && arguments
Braindead bug, when analyzing whether a use of 'arguments' escapes and seeing it flow to a phi node, we would analyze the uses of the components of the phi rather than the phi itself.

http://hg.mozilla.org/projects/jaegermonkey/rev/0f02561d061c
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 660202
You need to log in before you can comment on or make changes to this bug.