Last Comment Bug 660111 - Blocklist McAfee SiteAdvisor 3.3.1 due to [@ nsTArray<ObserverRef, nsTArrayDefaultAllocator>::AppendElements<ObserverRef>(ObserverRef const*, unsigned int) | nsObserverList::FillObserverArray(nsCOMArray<nsIObserver>&) ]
: Blocklist McAfee SiteAdvisor 3.3.1 due to [@ nsTArray<ObserverRef, nsTArrayDe...
Status: RESOLVED FIXED
[extension][hardblock][3rd-party-bust...
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Windows 7
: -- critical with 1 vote (vote)
: ---
Assigned To: Justin Scott [:fligtar]
:
Mentors:
Depends on: 658780 660289
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 16:41 PDT by Marcia Knous [:marcia - use ni]
Modified: 2016-03-07 15:30 PST (History)
25 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Macafee siteadvisor (902.96 KB, patch)
2011-07-03 15:06 PDT, alangeeves789
no flags Details | Diff | Splinter Review

Description Marcia Knous [:marcia - use ni] 2011-05-26 16:41:50 PDT
+++ This bug was initially created as a clone of Bug #658780 +++

I created this bug to track the work that was requested in Bug 658780.


=======================
It exists in 4.0.1, 5.0 and 6.0a1.
It is currently #1 top crasher in 5.0b2.
It happens at startup.

Stack traces are various:
0 	xul.dll 	nsTArray<ObserverRef,nsTArrayDefaultAllocator>::AppendElements<ObserverRef> 	obj-firefox/dist/include/nsTArray.h:773
1 	xul.dll 	nsObserverList::FillObserverArray 	xpcom/ds/nsObserverList.cpp:102
2 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
3 	xul.dll 	xul.dll@0x65c9f 	
4 	xul.dll 	nsHttpChannel::AsyncOpen 	netwerk/protocol/http/nsHttpChannel.cpp:3652
5 	xul.dll 	nsURILoader::OpenURI 	uriloader/base/nsURILoader.cpp:863
6 	xul.dll 	nsDocShell::DoChannelLoad 	docshell/base/nsDocShell.cpp:9048
7 	xul.dll 	nsDocShell::DoURILoad 	docshell/base/nsDocShell.cpp:8890
8 	xul.dll 	nsDocShell::InternalLoad 	docshell/base/nsDocShell.cpp:8555 

0 	xul.dll 	nsTArray<ObserverRef,nsTArrayDefaultAllocator>::AppendElements<ObserverRef> 	obj-firefox/dist/include/nsTArray.h:773
1 	xul.dll 	nsObserverList::FillObserverArray 	xpcom/ds/nsObserverList.cpp:102
2 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
3 	xul.dll 	xul.dll@0x65c9f 	
4 	xul.dll 	nsHttpChannel::AsyncOpen 	netwerk/protocol/http/nsHttpChannel.cpp:3652
5 	xul.dll 	nsXMLHttpRequest::Send 	content/base/src/nsXMLHttpRequest.cpp:2204
6 	xul.dll 	nsIXMLHttpRequest_Send 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:26818 

0 	xul.dll 	nsTArray<ObserverRef,nsTArrayDefaultAllocator>::AppendElements<ObserverRef> 	obj-firefox/dist/include/nsTArray.h:773
1 	xul.dll 	nsObserverList::FillObserverArray 	xpcom/ds/nsObserverList.cpp:102
2 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
3 	xul.dll 	xul.dll@0x65c9f 	
4 	xul.dll 	nsHttpChannel::AsyncOpen 	netwerk/protocol/http/nsHttpChannel.cpp:3652
5 	xul.dll 	imgLoader::LoadImage 	modules/libpr0n/src/imgLoader.cpp:1659
6 	xul.dll 	nsLoadGroup::AddRef 	netwerk/base/src/nsLoadGroup.cpp:204
7 	xul.dll 	nsImageBoxFrame::UpdateImage 	layout/xul/base/src/nsImageBoxFrame.cpp:271
8 	xul.dll 	nsFrame::Init 	layout/generic/nsFrame.cpp:372
...

0 	xul.dll 	nsTArray<ObserverRef,nsTArrayDefaultAllocator>::AppendElements<ObserverRef> 	obj-firefox/dist/include/nsTArray.h:773
1 	xul.dll 	nsObserverList::FillObserverArray 	xpcom/ds/nsObserverList.cpp:102
2 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:439
3 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:625
4 	xul.dll 	nsObserverService::NotifyObservers 	xpcom/ds/nsObserverService.cpp:182
5 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
6 	nspr4.dll 	PR_EnterMonitor 	nsprpub/pr/src/threads/prmon.c:99
7 		@0x9335bf 	
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
...

0 	xul.dll 	nsTArray<ObserverRef,nsTArrayDefaultAllocator>::AppendElements<ObserverRef> 	obj-firefox/dist/include/nsTArray.h:773
1 	xul.dll 	nsObserverList::FillObserverArray 	xpcom/ds/nsObserverList.cpp:102
2 	xul.dll 	SearchTable 	obj-firefox/xpcom/build/pldhash.c:472
3 	xul.dll 	xul.dll@0x65c9f 	
4 	xul.dll 	nsWindowWatcher::OpenWindow 	embedding/components/windowwatcher/src/nsWindowWatcher.cpp:418
5 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
6 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
7 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4727
8 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:716 
...

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&signature=nsTArray%3CObserverRef%2C%20nsTArrayDefaultAllocator%3E%3A%3AAppendElements%3CObserverRef%3E%28ObserverRef%20const*%2C%20unsigned%20int%29%20|%20nsObserverList%3A%3AFillObserverArray%28nsCOMArray%3CnsIObserver%3E%26%29
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-05-27 07:30:49 PDT
Specifically, the blocklist should be:

Extension ID: {B7082FAA-CB62-4872-9106-E42DD88EDE45}
Extension Version: <= 3.3.1
Firefox Version: >= 5.0a1
Comment 2 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-05-27 07:31:03 PDT
And it should be a hardblock.
Comment 3 Justin Scott [:fligtar] 2011-05-27 11:07:28 PDT
This is blocked in staging. Please test: https://wiki.mozilla.org/Blocklisting/Testing

I'll work on getting the website updated in the meantime... unfortunately mozilla.com isn't redirecting to our automatically updated page on AMO yet.
Comment 4 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-05-27 11:16:42 PDT
I can verify that this is blocked correctly in staging. The details URL goes to mozilla.com without the new info, but I presume that's normal because I didn't put a staging URL as "details".
Comment 5 Kev Needham [:kev] 2011-05-27 12:01:04 PDT
SiteAdvisor team notified that we'll be blocking all versions on 5.0a1 and higher.
Comment 6 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-05-27 12:44:15 PDT
kev, not "all versions" though, right?

I can also verify that 3.3.1 is correctly not blocked in Firefox 4.0.1
Comment 7 Justin Scott [:fligtar] 2011-05-27 13:43:32 PDT
Great, thanks. Website has been updated, so I'll block in production in a little bit.
Comment 8 Marcia Knous [:marcia - use ni] 2011-05-27 13:56:39 PDT
In testing the staging site in the lab, I am not getting the block when running Firefox 5 Beta 2 on Win 7. My STR are as follows:

1. Site Advisor 3.3.1 already installed on the machine.
2. Download Beta 2 version
3. Change the addons URL in about:config. Restart.
4. Put the string in the error console and Evaluate.

Currently I get only a Silverlight Plugin coming up in the Blocklist ping.
Comment 9 Justin Scott [:fligtar] 2011-05-27 14:01:40 PDT
I blocked in production a couple minutes before your comment. Can you see if the production block works for you?
Comment 10 Marcia Knous [:marcia - use ni] 2011-05-27 14:10:57 PDT
I just tried it live in Firefox Beta 3 and is it working on the same Win 7 machine. Likely it was user error but I will retest with Beta 2 just to be sure.
Comment 11 Justin Scott [:fligtar] 2011-05-27 14:13:33 PDT
Cool; thanks.
Comment 12 Marcia Knous [:marcia - use ni] 2011-05-27 14:13:56 PDT
Retried with Firefox 5 Beta 2 and it works as well live. Thanks.
Comment 13 Kev Needham [:kev] 2011-05-27 18:15:16 PDT
(In reply to comment #6)
> kev, not "all versions" though, right?

to clarify, I meant we should block all versions of Site Advisor for 5.0a1 and above. I have asked for a sample of an updated version before we remove the block. I realize the block is currently <= 3.3.1, but think we need to watch and adjust as necessary.
Comment 14 Kamal Bisht 2011-06-12 23:55:54 PDT
May I get confirmation whether SiteAdvisor all versions are blocked for Firefox 5 Beta or only <= 3.3.1 !! I have siteadvisor with version higher than 3.3.1 but it shows are blocked (imcompatible rather) for Firefox 5 Beta 2.
Comment 15 Scoobidiver (away) 2011-06-13 00:16:01 PDT
(In reply to comment #14)
> May I get confirmation whether SiteAdvisor all versions are blocked for
> Firefox 5 Beta or only <= 3.3.1 !! I have siteadvisor with version higher
> than 3.3.1 but it shows are blocked (imcompatible rather) for Firefox 5 Beta
> 2.
You're right. The current blocklisting blocks versions higher than 3.3.1:
<emItem  blockID="i38" id="{B7082FAA-CB62-4872-9106-E42DD88EDE45}">
<versionRange  minVersion="3.3.1" maxVersion="*" severity="0">
<targetApplication  id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
<versionRange  minVersion="5.0a1" maxVersion="*" />
Comment 16 Kamal Bisht 2011-06-13 02:04:18 PDT
OK. So is it possible to limit this to version < 3.5 ?? This version is getting used by Site Advisor Enterprise which is a different product (same UID is used due to legacy reasons) of McAfee and is not released to external world.If this version is released and found to be problematic in future then Firefox is free to block us.
Comment 17 Kev Needham [:kev] 2011-06-13 04:27:04 PDT
We haven't received any information on the update for SiteAdvisor yet which addresses the startup crash outlined in bug 658780 (which prevents users from starting Firefox 5 at all), and until that happens we can't remove the blocklist until we know that versioning information is good. If it's a different product, the UID should be changed (this can be done on an upgrade), and this has been outlined in the past. Until we get that info and can verify the crash is addressed, we can't remove the block. 

(In reply to comment #16)
> OK. So is it possible to limit this to version < 3.5 ?? This version is
> getting used by Site Advisor Enterprise which is a different product (same
> UID is used due to legacy reasons) of McAfee and is not released to external
> world.If this version is released and found to be problematic in future then
> Firefox is free to block us.
Comment 18 Kamal Bisht 2011-06-13 04:40:03 PDT
OK. Will check with compatibility checker. Thanks.
Comment 19 Scoobidiver (away) 2011-06-13 04:43:50 PDT
(In reply to comment #17)
> We haven't received any information on the update for SiteAdvisor yet which
> addresses the startup crash outlined in bug 658780 (which prevents users
> from starting Firefox 5 at all), and until that happens we can't remove the
> blocklist until we know that versioning information is good.
In that case, can you change the blocklisting description in https://www.mozilla.com/en-US/blocklist/ that says: "McAfee SiteAdvisor, version 3.3.1 and below for Firefox 5 and later."?
Comment 20 Kev Needham [:kev] 2011-06-13 04:52:06 PDT
Wil: Could you change the blocklist entry for this bug to read:

"McAfee SiteAdvisor for Firefox 5 and later. Reason: high volume of crashes and incompatible with Firefox 5 (see bug 660111)"

We'll update it when we get new versions (hopefully soon)
Comment 21 Wil Clouser [:clouserw] 2011-06-13 17:19:12 PDT
Done in r90477.  I didn't even know we were still maintaining this page.
Comment 22 tmd63 2011-06-22 03:36:33 PDT
Kev. Ref:The blocking of site advisor on version 5 or higher.
This issue has not affected Windows XP using Site Advisor 3.3.1 and Firefox 4.
Has anyone checked older Windows versions.
Comment 23 alangeeves789 2011-07-03 15:06:01 PDT
Created attachment 543700 [details] [diff] [review]
Macafee siteadvisor
Comment 24 im.fmouie 2012-01-01 20:16:15 PST
I WANT mcafee site advisor to run. If i cannot, then I want to remove this version of firefox and go back to the 3.(whatever) version I had before uploading this junk version of firefox.
Please tell me how to do this.
Comment 25 Larry Cashen 2015-02-19 07:56:32 PST
We are seeing this block also occurring with FF v31ESR and Siteadvisor v3.5.0.1278. Have the crash issues been tested against this version so the block can be lifted?
Comment 26 Larry Cashen 2015-02-19 07:59:20 PST
this version of Siteadvisor(3.5.0.1278) works fine with the consumer FF v35
Comment 27 Larry Cashen 2015-02-19 08:09:27 PST
If I can get access to a dev version of 31ESR I can test it
Comment 28 nvalenti 2015-06-10 15:10:13 PDT
Why would this error message appear on Firefox ESR 38.01 and 31.# versions when I am using SiteAdvisor Enterprise 3.5 Patch 3?  It makes no sense that I get this block on Firefox for new versions of McAfee SAE.

Note You need to log in before you can comment on or make changes to this bug.