Remove head_ipc_setup.js

RESOLVED FIXED in mozilla8

Status

()

Core
Networking
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jdm, Assigned: Paul Nanowiz)

Tracking

Trunk
mozilla8
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor=jdm])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Bug 534764 landed, and the comments say to remove the hack when this has occurred.
(Reporter)

Comment 1

6 years ago
Really simple bug for someone to get used to the process of contributing a patch.
Whiteboard: [good first bug][mentor=jdm]
(Assignee)

Comment 2

6 years ago
Hello...I would like to fix this bug. I am new here and very interested in learning. I write C/C++ and many other languages. Please let me work on this bug as I really want to learn how this whole thing works.
(Reporter)

Comment 3

6 years ago
Great! All you should need to do is remove the file netwerk/test/unit_ipc/head_ipc_setup.js and netwerk/cookie/test/unit_ipc/head_ipc_setup.js, then remove the references to those files from netwerk/test/unit_ipc/xpcshell.ini and netwerk/cookie/test/unit_ipc/xpcshell.ini. Does that make sense?

Comment 4

6 years ago
Paul, if you haven't already come across https://developer.mozilla.org/En/Developer_Guide then it may save some time/effort :-)

The following MXR searches should point you in the

Comment 5

6 years ago
(keyboard/user fail)

...right direction:
http://mxr.mozilla.org/mozilla-central/search?string=head_ipc_setup.js
http://mxr.mozilla.org/mozilla-central/find?string=head_ipc_setup.js&tree=mozilla-central&hint=
(Assignee)

Comment 6

6 years ago
Hello Everyone:

Thanks for providing me direction that will help to resolve this bug.

@Josh: Yes, I understand your explanation and should be able to work myself through the code to fix the error.
(Assignee)

Comment 7

6 years ago
Here is what I have done:

1. I downloaded the source 6.0b1
2. Next, I proceeded as Josh Matthews described: Removed the files netwerk/test/unit_ipc/head_ipc_setup.js and netwerk/cookie/test/unit_ipc/head_ipc_setup.js, then removed the references to the files from netwerk/test/unit_ipc/xpcshell.ini and netwerk/cookie/test/unit_ipc/xpcshell.ini.
3. Then, I rebuilt it: make -f client.mk build.

Is the next thing is to create the patch file using the instructions at: https://developer.mozilla.org/en/Creating_a_patch ?
(Reporter)

Comment 8

6 years ago
That's one way, but probably not the best way. You should get the source with mercurial from http://hg.mozilla.org/mozilla-central/, and that will allow you to create a patch much easier.
(Assignee)

Comment 9

6 years ago
I have now set up Mercurial on my computer and ready to build it I am not sure which version I should actually build. I have downloaded the mozilla-central (main development tree) version but I am also wondering if it should be the mozilla-beta (prerelease development tree) version. Please clarify so I can be sure I am working with the right version. 

Also, the "Assigned To" on this page says no one has been assigned to it, could you please assign to me? Thank you.
(Reporter)

Comment 10

6 years ago
mozilla-central is the place where all current development occurs, so that's the tree you want to be using.
Assignee: nobody → nanodevwiz
(Assignee)

Comment 11

6 years ago
I have one more question: using the information provided at https://developer.mozilla.org/en/Installing_Mercurial and https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_diff_and_patch_files.3F , I created mercurial.hgrc in my home folder as follows:

[ui]
username = Paul Nanowiz <nanodevwiz@yahoo.com>
merge = kdiff3 

[merge-tools]
kdiff3.args=--auto -L1 base --L2 local --L3 other $base $local $other -o $output
kdiff3.regkey=Software\KDiff3
kdiff3.regappend=\kdiff3.exe
kdiff3.fixeol=True
kdiff3.gui=True

[defaults]
qnew = -Ue

[extensions]
hgext.mq = 

[diff]
git = 1
showfunc = 1
unified = 8


However, when I use the command: hg qnew bugname.patch, I get an error: hg: unknown command 'qnew'
'qnew' is provided by the following extension:

    mq  manage a stack of patches

use "hg help extensions" for information on enabling extensions.

mq extension is enabled but it still gives an error, could you please advise what is wrong with the .hgrc file? Thank you.
(Assignee)

Comment 12

6 years ago
Created attachment 545778 [details]
Bug 660158 - Remove all references to head_ipc.js

Hello Jason Duell,

I learned from #introduction that you will be reviewing this patch after checkin, hence I am sending it with your name on it. I have also run "make" after the patch and everything seemed fine.

Please let me know your review comments when they are available.

Thank you.

Paul.
Attachment #545778 - Flags: checkin+
Comment on attachment 545778 [details]
Bug 660158 - Remove all references to head_ipc.js

Paul, it looks like you accidentally attached your .hgrc file instead of the patch?   Or do you still need help getting your .hgrc to work correctly?

If not, and you've made the changes for this bug and are ready for a review, follow the instructions here
  

  https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3f

to create a patch, and mark it "review?" with my email address as the requestee. (don't mark anything checkin+: clearing that flag for this.  Reviews come before checkins).

Thanks!
Attachment #545778 - Attachment is obsolete: true
Attachment #545778 - Attachment is patch: false
Attachment #545778 - Flags: checkin+
(Assignee)

Comment 14

6 years ago
Created attachment 545807 [details] [diff] [review]
Bug 660158 - Remove all references to head_ipc.js

Hello Jason Duell,

Sorry for the error in attaching the wrong file. I have now attached the one at /home/paul/Projects/src/.hg/patches. 

Thank you and apologies for the inconvenience. 

Paul.
Attachment #545807 - Flags: review?(jduell.mcbugs)
Comment on attachment 545807 [details] [diff] [review]
Bug 660158 - Remove all references to head_ipc.js

Review of attachment 545807 [details] [diff] [review]:
-----------------------------------------------------------------

+r.

Sending to try server just for quick sanity check: xpcshell-only run: 

  http://hg.mozilla.org/try/rev/87e1007b08c8

Paul: this is just so we run the tests on all platforms before we check the code in.
Attachment #545807 - Flags: review?(jduell.mcbugs) → review+
Try is green.  Landed on mozilla-inbound:

  http://hg.mozilla.org/integration/mozilla-inbound/rev/6832ae71433c

Paul: if that's green too, your code will "automatically" (by magical merge-sheriffs :) get checked into mozilla-central, and this will be marked FIXED.

Thanks for your help!
Whiteboard: [good first bug][mentor=jdm] → [good first bug][mentor=jdm][inbound]
This (along with most things committed on Friday afternoon) was backed out of mozilla-inbound in order to clear up orange.
Whiteboard: [good first bug][mentor=jdm][inbound] → [good first bug][mentor=jdm]
Re-marking checkin-needed.

Paul: What Joe meant was that some of the automated tests on the mozilla-inbound branch were failing (so show up orange instead of green): http://dev.philringnalda.com/tbpl/?tree=Mozilla-Inbound . 

Normally it's possible to tell what caused the breakage and back just that out, but in this case mozilla-inbound ended up in a bit of a mess, so a bunch of stuff has been pulled out as the easiest solution.

Since we know this patch wasn't the cause (since it's already been tested via it's own dedicated try server test run in comment 15: http://dev.philringnalda.com/tbpl/?tree=Try&rev=87e1007b08c8), I've marked this bug as checkin-needed again (in the keywords field). This means it will show up for anyone who has commit privileges and is feeling altruistic - so that they can land it again :-)
Status: NEW → ASSIGNED
Keywords: checkin-needed
OS: Windows XP → All
Hardware: x86 → All
Thanks, Paul and Ed.

http://hg.mozilla.org/integration/mozilla-inbound/rev/30b96322b425
Keywords: checkin-needed

Updated

6 years ago
Flags: in-testsuite-
Target Milestone: --- → mozilla8
http://hg.mozilla.org/mozilla-central/rev/30b96322b425
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

6 years ago
Thanks to everyone for help with my first contribution...now will go hunting for more bugs and things to do:)
You need to log in before you can comment on or make changes to this bug.