About:memory vertical lines are not straight

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: vlad.ghetiu, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110525 Firefox/6.0a2

About:memory vertical lines are not straight

Steps to reproduce:

1. Go to about:memory

Actual results:

You should see that the vertical lines are not straight.

Expected result:

The lines should be straight.

Comment 1

7 years ago
WFM. At lest I see no obvious non-straight lines.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110527 Firefox/6.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1

Are your lines jagged or misaligned, or what do they look like?

Are you able to attach a screen shoot so everyone knows what to look for?
(Reporter)

Comment 2

7 years ago
Created attachment 536028 [details]
vertical lines

Comment 3

7 years ago
(In reply to comment #2)
> Created attachment 536028 [details]
> vertical lines

Thanks!

I didn't see something like that in comment 1, and this is still a WFM in:
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110529 Firefox/7.0a1

Comment 4

7 years ago
FWIW, Nicholas Nethercote (developer of said feature) already knew this, and didn't think the added work was worth it (if fixable at all) :

http://blog.mozilla.com/nnethercote/2011/05/02/a-better-aboutmemory-stage-1/
http://blog.mozilla.com/nnethercote/files/2011/05/aboutmemory-mac.png
It's just ASCII art, AFAICT it happens just because the in font used on Mac the unicode box drawing chars don't line up properly.  Which seems like a Mac font bug.

Bug 654917 is the proper fix for this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.