Last Comment Bug 660279 - Truncated "Learn more" and button in geolocation doorhanger (does not fit, too long, Russian, Esperanto)
: Truncated "Learn more" and button in geolocation doorhanger (does not fit, to...
Status: VERIFIED FIXED
[bugday-2011-05-27]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Firefox 7
Assigned To: :Margaret Leibovic
:
Mentors:
http://gavinsharp.com/tmp/geo.html
Depends on: 615483
Blocks: 615481 617270
  Show dependency treegraph
 
Reported: 2011-05-27 11:03 PDT by [:Aleksej]
Modified: 2011-06-02 02:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot of the bug in Esperanto and Russian Aurora 20110527 for Linux-x86_64 (with a Shiki-Colors GTK theme) (59.47 KB, image/png)
2011-05-27 11:03 PDT, [:Aleksej]
no flags Details
patch (2.13 KB, patch)
2011-05-30 14:34 PDT, :Margaret Leibovic
dao+bmo: review+
Details | Diff | Splinter Review

Description [:Aleksej] 2011-05-27 11:03:48 PDT
Created attachment 535688 [details]
screenshot of the bug in Esperanto and Russian Aurora 20110527 for Linux-x86_64 (with a Shiki-Colors GTK theme)

It seems that the button in the geolocation doorhanger is right-aligned at the center of the doorhanger, so, when it is long, it pushes the "Learn more" text out to the left (e.g. in Esperanto), and can itself be truncated (e.g. in Russian).

Nightly
WFM: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b8pre) Gecko/20101203 Firefox/4.0b8pre
stretched icon: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre
stretched icon: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101206 Firefox/4.0b8pre
bug: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b8pre) Gecko/20101208 Firefox/4.0b8pre

Beta:
bug: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

Aurora:
bug: Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110412 Firefox/4.2a1pre
bug: Mozilla/5.0 (X11; Linux x86_64; rv:5.0a2) Gecko/20110506 Firefox/5.0a2
Comment 1 Dão Gottwald [:dao] 2011-05-27 14:34:06 PDT
Bug 615481 having used a px value for the description's max-width is probably at fault here.
Comment 2 :Margaret Leibovic 2011-05-30 14:34:45 PDT
Created attachment 536176 [details] [diff] [review]
patch

I agree that using em instead of px for the max-width will make the notification wider to accommodate more text, but it looks like something else is going wrong in this screenshot. It looks like the vbox that contains the close button is taking up more space than it should. Even if the description text wraps, the menubutton should still be aligned farther to the right. I guess we can investigate that further if this fix doesn't fix the problem.

I somewhat arbitrarily picked 24em because that looks right on my platform. Feel free to offer suggestions if there's a smarter way to choose this value.
Comment 3 :Margaret Leibovic 2011-05-31 14:45:43 PDT
http://hg.mozilla.org/mozilla-central/rev/de924c37271e
Comment 4 Robert Kaiser 2011-06-01 06:40:09 PDT
Erm, I only noticed this because of seeing the checkin - but em is really a (line) height unit, widths should use ch units that are tied to character widths.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-01 11:00:43 PDT
Yeah, I hear people say that a lot, but no one has ever explained to me why that actually matters in practice.
Comment 6 Robert Kaiser 2011-06-01 12:03:53 PDT
(In reply to comment #5)
> Yeah, I hear people say that a lot, but no one has ever explained to me why
> that actually matters in practice.

We had a number of cases where dialogs would actually become too narrow if people had a system font that has wider than high characters. Those are edge cases, but using ch for widths we can deal with that nicely. Also, we saw that due to different OSes using different system fonts (with different character widths), what looks like a reasonable width on one could look badly off on the other. The "em" unit mostly corresponds to the "font size", which actually is the default line height in the end, and depending on the font, a width of 30em might fit 60 or 20 characters...
Comment 7 Simona B [:simonab ] 2011-06-02 02:58:53 PDT
Verified issue on both locals Esperanto and Russian.

Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110601 Firefox/6.0a2 -eo

Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110601 Firefox/6.0a2 -ru

The Geolocation doorhangers are now complete.

Note You need to log in before you can comment on or make changes to this bug.