Error when pushing to user repo: Sending messages to pulse.mozilla.org, Hook returned an exception: 'NoneType' object has no attribute 'filerev'

RESOLVED WONTFIX

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: christian)

Tracking

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1334] )

(Reporter)

Description

6 years ago
(Not sure if this is the right component.)

I get the following error when I push to my user repository:

$ hg push
pushing to ssh://hg.mozilla.org/users/jlebar_mozilla.com/patches
searching for changes
remote: adding changesets                            
remote: adding manifests
remote: adding file changes
remote: added 13 changesets with 30 changes to 15 files
remote: Sending messages to pulse.mozilla.org
remote: Please do not interrupt...
remote: ERROR: Hook returned an exception: 'NoneType' object has no attribute 'filerev'
remote: Ignoring and continuing the push...
remote: Trying to insert into pushlog.
remote: Please do not interrupt...
remote: Inserted into the pushlog db successfully.
This hook is owned by Christian, and deployed by IT.

Doesn't look like this blocks pushing, so probably not high priority.

Also, maybe related to bug 660208?
Component: Release Engineering → Hg: Customizations
QA Contact: release → hg.customizations
Perhaps a fallout from bug 603029?
I get this when pushing a merge to services-central (the error looks like it doesn't handle merge commits quite right.)
Probably a dupe of bug 660137
(Assignee)

Comment 5

6 years ago
I might not be handling merges right...I'll add some more tests.
(Assignee)

Updated

6 years ago
Assignee: nobody → clegnitto
Status: NEW → ASSIGNED

Comment 6

6 years ago
got this on http://hg.mozilla.org/l10n-central/es-ES/pushloghtml?changeset=1d618e2ecb90, which contains two merges.
I got it with https://hg.mozilla.org/comm-central/pushloghtml?changeset=0d12ed87f045, which doesn't actually contain any merges.
(Assignee)

Comment 8

6 years ago
Yep, merges and deleted files. I have a lot more tests, just making sure I got everything before rolling out.
I got this on http://hg.mozilla.org/try/pushloghtml?changeset=740b6956cabd which has neither merges nor deleted files, but the tip changeset has no file changes at all in it (it's just there for the try syntax).
Product: mozilla.org → Release Engineering
Product: Release Engineering → Developer Services

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/282]

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/282] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1325] [kanban:engops:https://kanbanize.com/ctrl_board/6/282]

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1325] [kanban:engops:https://kanbanize.com/ctrl_board/6/282] [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1329] [kanban:engops:https://kanbanize.com/ctrl_board/6/282] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1329] [kanban:engops:https://kanbanize.com/ctrl_board/6/282] [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1330] [kanban:engops:https://kanbanize.com/ctrl_board/6/282]

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1330] [kanban:engops:https://kanbanize.com/ctrl_board/6/282] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1334] [kanban:engops:https://kanbanize.com/ctrl_board/6/282]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1334] [kanban:engops:https://kanbanize.com/ctrl_board/6/282] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1334]
Pulse hook is not currently deployed. Closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.