Closed Bug 660365 Opened 11 years ago Closed 11 years ago

some mobile builds have binaries with the processname of org.mozilla.fennec_unofficial

Categories

(Release Engineering :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bear, Assigned: aki)

References

Details

(Whiteboard: [android][tegra])

Attachments

(3 files)

need to find out if this process name has to be passed downstream to the remote test code and if that is what is causing all of the try android installApp steps to fail

This is where i'm seeing the binary name (part of the logcat dump):

05-27 14:47:21.239 W/PackageManager( 1017): Code path for pkg : org.mozilla.fennec_unofficial changing from /data/app/org.mozilla.fennec_unofficial-1.apk to /data/app/org.mozilla.fennec_unofficial-2.apk
05-27 14:47:21.239 W/PackageManager( 1017): Resource path for pkg : org.mozilla.fennec_unofficial changing from /data/app/org.mozilla.fennec_unofficial-1.apk to /data/app/org.mozilla.fennec_unofficial-2.apk
Whiteboard: [android][tegra]
yes, if that is what fennec is called on the device, then yes, that does need to be passed down.  I think I remember fennec changing that for some reason.  I think it means "unofficial branding".
Attachment #536480 - Flags: review?(bear)
Attachment #536480 - Flags: review?(bear) → review+
Attachment #536481 - Flags: review?(bear) → review+
I had to add this:

'tracemonkey': 'org.mozilla.fennec',

to get my tracemonkey sendchanges to work in staging - the tracemonkey apk's are using org.mozilla.fennec for the binary name
That's because the nightly is from last night, before all this landed.
Tonight's may die due to https://bugzilla.mozilla.org/show_bug.cgi?id=557260#c141 .
Tracemonkey also hasn't merged from m-c in a while if there are changes in m-c that you need. eg they still have a version of 6.0a1. Last common rev is 11d04991cdd0 if I'm reading these tea leaves correctly.
Looks like they have the unofficial branding, so the mozconfig change yesterday should make tracemonkey be fennec_unofficial (though I may be wrong).
http://hg.mozilla.org/tracemonkey/file/default/mobile/branding/unofficial
Summary: some mobile try builds have binaries with the processname of org.mozilla.fennec_unofficial → some mobile builds have binaries with the processname of org.mozilla.fennec_unofficial
yep, once I realized that the nightly dir was changed to be s/android-r7/android/ I confirmed that _unofficial is present.  changing the test environment to work with that and restarting
Duplicate of this bug: 660951
[12:43]	<aki>	we can change 'em all to use nightly branding if you want
[12:43]	<mfinkle>	aki, I could live with that
[12:43]	<ctalbert>	yeah we could just change the onchange builds and life would be fine
[12:43]	<mfinkle>	then we are testing what the user sees
[12:43]	<blassey>	aki: that works for me
[12:43]	<aki>	ok
[12:43]	<bmoss>	good solution guys

This patch will remove all fennec_unofficials from our depend/nightly builds, so the other two patches won't be needed.
Attachment #536706 - Flags: review?(bear)
Attachment #536706 - Flags: review?(bear) → review+
Comment on attachment 536706 [details] [diff] [review]
readd android branding to all our mozconfigs

http://hg.mozilla.org/build/buildbot-configs/rev/97f0d1337db9

This bug should be fixed as soon as this merges.
Attachment #536706 - Flags: checked-in+
Looks like this is Aki's bug.
Assignee: nobody → aki
This made it to production today.
Should be fixed.
Kicked off tracemonkey and jaegermonkey android nightlies.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.