Last Comment Bug 660374 - Mulitple lines of this spammed on startup: "WARNING: Serializing document without system principal: file nsXULPrototypeDocument.cpp line 424"
: Mulitple lines of this spammed on startup: "WARNING: Serializing document wit...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 592943
  Show dependency treegraph
 
Reported: 2011-05-27 16:13 PDT by Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
Modified: 2011-06-09 18:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-05-27 16:13:37 PDT
STR:
 1. Start a debug build from this afternoon or later.
    (fresh profile optional but not required)

ACTUAL RESULTS:
Among the first few lines of output is 4 consecutive instances of:
{
"WARNING: Serializing document without system principal: file nsXULPrototypeDocument.cpp line 424"
}
... followed by 2 more instances, after some other terminalspew goes by (for a total of 6)

This warning was just added today, here:
http://hg.mozilla.org/mozilla-central/rev/eaa69ae330ab#l7.12
as part of bug 592943
(and the comment above the warning says that this is "worrisome"...)
Comment 1 Boris Zbarsky [:bz] 2011-05-27 20:54:00 PDT
Would be good to change the warning to include the URI.  ;)
Comment 2 Michael Wu [:mwu] 2011-06-09 18:18:40 PDT
It turns out the warning was just wrong and we were warning when the document *had* a system principal instead of when it doesn't.

This bug was resolved by the backout, and shouldn't come back since I have a fix for the warning in the original bug. I do have a patch to include the URI, but the warning doesn't appear anymore so I don't care so much about pushing for it.

Note You need to log in before you can comment on or make changes to this bug.