Note: There are a few cases of duplicates in user autocompletion which are being worked on.

After closing Print preview, the favicon and the domain name highlighting disappears from the navigation bar, and Back/Forward buttons are disabled

VERIFIED FIXED in Firefox 6

Status

()

Firefox
Location Bar
--
minor
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Dan Wolff, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 7
regression
Points:
---

Firefox Tracking Flags

(firefox6 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110527 Firefox/6.0a2
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110527 Firefox/6.0a2

Closing "Print preview" seems to reset some details of the the navigation bar.

, specifically the favicon, and instead of highlighting the domain name, all of the text becomes black.

Reproducible: Always

Steps to Reproduce:
1. Go to any website with a favicon, e.g. http://www.mozilla.org/
2. Choose print preview (File -> Print preview)
3. Exit print preview by clicking the Close button

Actual Results:  
* The favicon in the navigation toolbar is reset to the dimmed version used for new tabs.
* The URL in the location field becomes all-black, instead of highlighting the domain (like in Firefox < 6).

Expected Results:  
The navigation toolbar keeps the visual aspects it had before going to Print preview.

Perhaps there are other cases where the navigation toolbar is temporarily blocked, where the same problem occurs.

Comment 1

6 years ago
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/0cf4fa02c0f2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1 ID:20110527030642
and
http://hg.mozilla.org/releases/mozilla-aurora/rev/a690014bb7aa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.2) Gecko/20110508 Firefox/6.0a2 ID:20110527042002
Blocks: 451833
Status: UNCONFIRMED → NEW
tracking-firefox6: --- → ?
tracking-firefox7: --- → ?
Ever confirmed: true
OS: Linux → All
Version: unspecified → Trunk
(Assignee)

Comment 2

6 years ago
Why would this need to be tracked for a particular release?
tracking-firefox6: ? → ---
tracking-firefox7: ? → ---

Comment 3

6 years ago
(In reply to comment #2)
> Why would this need to be tracked for a particular release?
Sorry.

Error appears When closeing print preview:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsISelectionController.getSelection]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://browser/content/urlbarBindings.xml :: formatValue :: line 152"  data: no]
Source File: chrome://browser/content/tabbrowser.xml
Line: 414

Warning: XUL box for _moz_generated_content_after element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://browser/content/browser.xul
Line: 0
Blocks: 661422
(Assignee)

Updated

6 years ago
No longer blocks: 661422
Duplicate of this bug: 661422
(Assignee)

Comment 5

6 years ago
Created attachment 536831 [details] [diff] [review]
patch

This also fixes this strict warning, which I get twice when entering print preview:

Warning: reference to undefined property this.boxObject.QueryInterface(Components.interfaces.nsIContainerBoxObject).docShell
Source File: chrome://global/content/bindings/browser.xml
Line: 0

And this when exiting print preview:

Warning: reference to undefined property this.popupBoxObject.popupState
Source File: chrome://global/content/bindings/popup.xml
Line: 0
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #536831 - Flags: review?(gavin.sharp)
Comment on attachment 536831 [details] [diff] [review]
patch

So this is actually fallout from moving the tabs toolbar, right? We should probably have a test for print preview that would have caught this.
Attachment #536831 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 7

6 years ago
> So this is actually fallout from moving the tabs toolbar, right? We should
> probably have a test for print preview that would have caught this.

Moving the tabs toolbar where? Do you mean bug 347930? I don't think I see the connection.

The error occurs during updateCurrentBrowser, so I think bug 544018 caused this by adding/removing a tab for print preview.
(In reply to comment #7)
> Do you mean bug 347930? I don't think I see the connection.

Yes, that's what I meant. I thought the error was related to the tabbrowser-tabs binding not being applied, but I guess it's actually the URL bar not having a frame (and therefore not having a selection). I guess I was confusing this with bug 642355.

> The error occurs during updateCurrentBrowser, so I think bug 544018 caused
> this by adding/removing a tab for print preview.

Ah, ok.
This came up in triage since a nominated bug was dup'd to it. We don't think this needs release-specific tracking, but would like to see the patch nominated for aurora if it bakes cleanly
Summary: After closing Print preview, the favicon and the domain name highlighting disappears from the navigation bar → After closing Print preview, the favicon and the domain name highlighting disappears from the navigation bar, and Back/Forward buttons are disabled
Hardware: x86 → All
(adding 'regression' keyword for the back/forward button breakage)
Keywords: regression
(Assignee)

Comment 11

6 years ago
http://hg.mozilla.org/mozilla-central/rev/2b7732c590bd
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 7
(Assignee)

Updated

6 years ago
Attachment #536831 - Flags: approval-mozilla-aurora?
Attachment #536831 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

6 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/3f9c13d0d700
status-firefox6: --- → fixed
Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110609 Firefox/7.0a1

Verified on mozilla-central builds using the STR from Comment 0, on Win XP, Win7 and Ubuntu 10.10.

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.