Last Comment Bug 660404 - Pages do not get bfcached when navigating to a multipart response
: Pages do not get bfcached when navigating to a multipart response
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla7
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 19:51 PDT by Boris Zbarsky [:bz]
Modified: 2011-06-02 08:56 PDT (History)
3 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow storing the previous page in bfcache even if the new one is a multipart response. (1.78 KB, patch)
2011-05-27 19:52 PDT, Boris Zbarsky [:bz]
bugs: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] 2011-05-27 19:51:03 PDT
This happens because there are two live requests in the loadgroup during unload in this situation: the multipart response and the part being loaded.

This happens most simply when leaving the bugzilla query page by doing a query.
Comment 1 Boris Zbarsky [:bz] 2011-05-27 19:52:06 PDT
Created attachment 535806 [details] [diff] [review]
Allow storing the previous page in bfcache even if the new one is a multipart response.
Comment 2 Olli Pettay [:smaug] 2011-05-28 13:41:21 PDT
Comment on attachment 535806 [details] [diff] [review]
Allow storing the previous page in bfcache even if the new one is a multipart response.

r=me, but this needs tests.
Comment 3 Boris Zbarsky [:bz] 2011-06-01 05:03:01 PDT
I'll see what I can do....
Comment 4 Boris Zbarsky [:bz] 2011-06-01 19:03:21 PDT
Pushed http://hg.mozilla.org/projects/cedar/rev/f0270e2a21bc with test.
Comment 5 Mounir Lamouri (:mounir) 2011-06-02 04:18:03 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/f0270e2a21bc

Note You need to log in before you can comment on or make changes to this bug.