When opening a torrent default action is not being performed

RESOLVED DUPLICATE of bug 453455

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 453455
7 years ago
7 years ago

People

(Reporter: George R. Goffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When I open a link to a .torrent file, I get a popup which has the desired action. I choose open by ktorrent. Below that is a check box which says "Do this automatically for files like this from now on." I check this box and poke the "ok" button. When opening the next .torrent file, I get the popup again... this time with the check box checked. It appears that the "default" action is not happening. Is this a server issue? This works on some sites but not on others.



Reproducible: Always

Steps to Reproduce:
1.see details
2.
3.

Actual Results:  
see details

Expected Results:  
see details

Comment 1

7 years ago
Yes it is a server issue, they shouldn't be sending the HTTP header "content-disposition: attachment" as that was originally meant as an email mime header.

However the reality is more and more web servers are doing this, and your end user experience should be what matters
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
You need to log in before you can comment on or make changes to this bug.