Last Comment Bug 660534 - Useless use of PromiseFlatCString
: Useless use of PromiseFlatCString
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla7
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 06:29 PDT by neil@parkwaycc.co.uk
Modified: 2011-06-13 20:43 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (1.14 KB, patch)
2011-05-29 06:30 PDT, neil@parkwaycc.co.uk
joe: review+
Details | Diff | Review

Description neil@parkwaycc.co.uk 2011-05-29 06:29:14 PDT
There's no point calling PromiseFlatCString on a known flat string.
Comment 1 neil@parkwaycc.co.uk 2011-05-29 06:30:10 PDT
Created attachment 535931 [details] [diff] [review]
Proposed patch
Comment 2 Joe Drew (not getting mail) 2011-06-09 11:21:41 PDT
Comment on attachment 535931 [details] [diff] [review]
Proposed patch

Review of attachment 535931 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 neil@parkwaycc.co.uk 2011-06-09 13:29:20 PDT
Pushed changeset cc8b37b43c5a to mozilla-central.
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2011-06-09 14:04:35 PDT
Backed out because of red on Windows desktop mobile build:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307650903.1307652099.19955.gz
Comment 5 neil@parkwaycc.co.uk 2011-06-09 14:12:31 PDT
Not worth my while checking things in any more, some other loser can do it.
Comment 6 Daniel Holbert [:dholbert] (largely AFK until June 28) 2011-06-13 18:56:56 PDT
Imported & pushed the same cset from comment 3:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3d68f32c68b7
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2011-06-13 20:43:39 PDT
http://hg.mozilla.org/mozilla-central/rev/3d68f32c68b7

Note You need to log in before you can comment on or make changes to this bug.