Last Comment Bug 660535 - Useless use of PromiseFlatCString
: Useless use of PromiseFlatCString
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla7
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 06:31 PDT by neil@parkwaycc.co.uk
Modified: 2011-08-31 07:29 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (1.25 KB, patch)
2011-05-29 06:32 PDT, neil@parkwaycc.co.uk
cjones.bugs: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-05-29 06:31:17 PDT
There's no point calling PromiseFlatCString on known flat strings.
Comment 1 neil@parkwaycc.co.uk 2011-05-29 06:32:07 PDT
Created attachment 535932 [details] [diff] [review]
Proposed patch
Comment 2 neil@parkwaycc.co.uk 2011-06-09 13:27:36 PDT
Pushed changeset fba5bf34ad72 to mozilla-central.
Comment 3 :Ehsan Akhgari 2011-06-09 14:04:48 PDT
Backed out because of red on Windows desktop mobile build:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307650903.1307652099.19955.gz
Comment 4 neil@parkwaycc.co.uk 2011-06-09 14:12:26 PDT
Not worth my while checking things in any more, some other loser can do it.
Comment 5 Daniel Holbert [:dholbert] 2011-06-13 18:57:33 PDT
Imported & pushed the same cset from comment 2:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3d68f32c68b7
Comment 6 Daniel Holbert [:dholbert] 2011-06-13 18:58:24 PDT
(In reply to comment #5)
> http://hg.mozilla.org/integration/mozilla-inbound/rev/3d68f32c68b7
sorry, that's wrong -- copy-paste fail -- the pushed cset here is:
http://hg.mozilla.org/integration/mozilla-inbound/rev/10f50879c454
Comment 8 Mihaela Velimiroviciu (:mihaelav) 2011-08-31 05:26:09 PDT
Verified that file ipc/glue/GeckoChildProcessHost.cpp is updated in mozilla-central repository: "PromiseFlatCString " is not used anymore.

Is this enough to verify the bug as verified-fixed?

THank you!
Comment 9 neil@parkwaycc.co.uk 2011-08-31 06:46:25 PDT
(In reply to Mihaela Velimiroviciu from comment #8)
> Verified that file ipc/glue/GeckoChildProcessHost.cpp is updated in
> mozilla-central repository: "PromiseFlatCString " is not used anymore.
> 
> Is this enough to verify the bug as verified-fixed?

That's about all you can do, yes.
Comment 10 Mihaela Velimiroviciu (:mihaelav) 2011-08-31 07:29:52 PDT
Changing status to VERIFIED-FIXED based on comment 9

Note You need to log in before you can comment on or make changes to this bug.