Last Comment Bug 660536 - Useless uses of PromiseFlat(C)String
: Useless uses of PromiseFlat(C)String
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla7
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 06:34 PDT by neil@parkwaycc.co.uk
Modified: 2011-06-13 20:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (8.23 KB, patch)
2011-05-29 06:35 PDT, neil@parkwaycc.co.uk
bugs: review+
Details | Diff | Splinter Review
Updated for bitrot (8.27 KB, patch)
2011-06-09 16:11 PDT, neil@parkwaycc.co.uk
neil: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-05-29 06:34:24 PDT
There's no point calling PromiseFlat(C)String on known flat strings.
Comment 1 neil@parkwaycc.co.uk 2011-05-29 06:35:22 PDT
Created attachment 535933 [details] [diff] [review]
Proposed patch
Comment 2 neil@parkwaycc.co.uk 2011-06-09 13:26:07 PDT
Pushed changeset b9dab5588ce1 to mozilla-central.
Comment 3 :Ehsan Akhgari 2011-06-09 14:05:02 PDT
Backed out because of red on Windows desktop mobile build:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307650903.1307652099.19955.gz
Comment 4 neil@parkwaycc.co.uk 2011-06-09 14:12:27 PDT
Not worth my while checking things in any more, some other loser can do it.
Comment 5 neil@parkwaycc.co.uk 2011-06-09 16:11:25 PDT
Created attachment 538376 [details] [diff] [review]
Updated for bitrot

Bug 660721 divergently renamed nsObjectFrame.cpp to nsPluginInstanceOwner.cpp
Comment 6 Daniel Holbert [:dholbert] 2011-06-13 18:41:10 PDT
(In reply to comment #5)
> Bug 660721 divergently renamed nsObjectFrame.cpp to nsPluginInstanceOwner.cpp

That means it made a copy of that file, I think.

It looks like you just changed your patch with s/nsObjectFrame.cpp/nsPluginInstanceOwner.cpp/, but presumably you *also* want to patch the original file (nsObjectFrame.cpp), right?
Comment 7 Daniel Holbert [:dholbert] 2011-06-13 18:44:35 PDT
(In reply to comment #6)
> It looks like you just changed your patch with
> s/nsObjectFrame.cpp/nsPluginInstanceOwner.cpp/, but presumably you *also*
> want to patch the original file (nsObjectFrame.cpp), right?

Ah, nevermind - while nsObjectFrame.cpp still exists, it no longer has the relevant chunk of code. (Bug 660721 deleted that chunk, along with creating the copy.)
Comment 8 Daniel Holbert [:dholbert] 2011-06-13 18:58:59 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f68c52f253e7

Note You need to log in before you can comment on or make changes to this bug.