Last Comment Bug 660638 - OOM in Compiler::compileScript when |script| is not checked
: OOM in Compiler::compileScript when |script| is not checked
Status: RESOLVED FIXED
[fixed-in-tracemonkey]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Paul Biggar
:
:
Mentors:
: 606665 (view as bug list)
Depends on:
Blocks: 624094
  Show dependency treegraph
 
Reported: 2011-05-30 06:59 PDT by Paul Biggar
Modified: 2013-12-27 14:33 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
fix OOM (1.27 KB, patch)
2011-05-30 06:59 PDT, Paul Biggar
jwalden+bmo: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Paul Biggar 2011-05-30 06:59:44 PDT
Created attachment 536086 [details] [diff] [review]
fix OOM

In Compiler::compileScript, |script| can be NULL when passed to defineGlobals. This returns NULL instead.
Comment 2 Paul Biggar 2011-06-06 14:37:53 PDT
Um, I mean:

http://hg.mozilla.org/tracemonkey/rev/29b7c7a14506
Comment 3 Bill McCloskey (:billm) 2011-06-07 11:17:29 PDT
*** Bug 606665 has been marked as a duplicate of this bug. ***
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-06-13 10:59:58 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/29b7c7a14506
Comment 5 Bob Clary [:bc:] 2011-06-18 09:08:49 PDT
This affects 2.0.0, beta and aurora. Paul, is this low enough risk to make it into Firefox 6?
Comment 6 Paul Biggar 2011-06-20 09:24:13 PDT
Sure, this is pretty low-risk.
Comment 7 Asa Dotzler [:asa] 2011-06-21 14:54:29 PDT
Comment on attachment 536086 [details] [diff] [review]
fix OOM

Approved for Aurora landing. (not tracking, though). Please land as soon as possible since Aurora only has a couple of weeks left.
Comment 8 Paul Biggar 2011-06-21 16:18:48 PDT
Just to clarify, who is going to land this in aurora? Is it me? I'm OK with that, I just want to be sure :)
Comment 9 David Mandelin [:dmandelin] 2011-06-21 17:04:32 PDT
(In reply to comment #8)
> Just to clarify, who is going to land this in aurora? Is it me? 

Yes.
Comment 10 Paul Biggar 2011-06-24 16:17:53 PDT
Landed in aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/f69cd8f15cdf

Note You need to log in before you can comment on or make changes to this bug.