Last Comment Bug 660662 - Eliminate NS_(ceil|floor)
: Eliminate NS_(ceil|floor)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-30 08:53 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2011-08-14 05:46 PDT (History)
4 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove NS_(floor|ceil) (37.42 KB, patch)
2011-05-30 10:29 PDT, Jeff Muizelaar [:jrmuizel]
roc: review+
Details | Diff | Review
Remove unnecessary floor in nsNativeTheme::QueueAnimatedContentForRefresh (997 bytes, patch)
2011-06-02 12:50 PDT, Jeff Muizelaar [:jrmuizel]
bent.mozilla: review+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2011-05-30 08:53:20 PDT
I don't see any reason for having these guys around.
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-05-30 10:29:44 PDT
Created attachment 536122 [details] [diff] [review]
Remove NS_(floor|ceil)
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-30 15:15:48 PDT
Comment on attachment 536122 [details] [diff] [review]
Remove NS_(floor|ceil)

Review of attachment 536122 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-06-02 12:50:24 PDT
Created attachment 536959 [details] [diff] [review]
Remove unnecessary floor in nsNativeTheme::QueueAnimatedContentForRefresh

MSVC wasn't building the patch because we were flooring an int. This patch gets rid of that.
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-06-21 13:48:33 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/188621c4b912
Comment 5 Matt Brubeck (:mbrubeck) 2011-06-22 10:15:39 PDT
attachment 536959 [details] [diff] [review] in mozilla-central for Firefox 7:
http://hg.mozilla.org/mozilla-central/rev/188621c4b912

Not resolving the bug because attachment 536122 [details] [diff] [review] has not yet landed.  You can resolve this bug when that patch lands (or if it's no longer needed).
Comment 6 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-14 04:49:51 PDT
http://hg.mozilla.org/mozilla-central/rev/6fd7a1b9ef64

Note You need to log in before you can comment on or make changes to this bug.