Last Comment Bug 660663 - Make element.dir a real enumerated attribute
: Make element.dir a real enumerated attribute
Status: VERIFIED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
http://www.w3c-test.org/html/tests/su...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-30 08:53 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-09-14 06:13 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.49 KB, patch)
2011-05-30 08:53 PDT, :Ms2ger (⌚ UTC+1/+2)
bzbarsky: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-05-30 08:53:29 PDT
Created attachment 536107 [details] [diff] [review]
Patch v1

It currently hand-rolls similar code.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-06-02 14:55:54 PDT
Comment on attachment 536107 [details] [diff] [review]
Patch v1

r=me
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-06-04 03:55:17 PDT
http://hg.mozilla.org/mozilla-central/rev/f96c523a2178
Comment 3 Eric Shepherd [:sheppy] 2011-08-04 10:48:16 PDT
I'm not sure what needs documenting here; this looks like it's a strictly internal tweak that doesn't really affect anyone. What am I missing?
Comment 4 Eric Shepherd [:sheppy] 2011-08-04 11:33:32 PDT
Documentation updated after talking to Ms2ger for a bit in IRC:

https://developer.mozilla.org/en/DOM/element.dir

Also mentioned on Firefox 7 for developers.
Comment 5 Ioana (away) 2011-09-14 06:13:53 PDT
content/html/content/test/test_bug660663.html passed on:
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
+ Aurora (Fx 8.0a2) & Nightly (Fx 9.0a1).

Test Results:
Passed: 31
Failed: 0
Todo: 4
todo | auto should be accepted as a valid value for dir - got "", expected "auto"
todo | Enumerated attributes should be case-insensitive. - got "", expected "auto"
todo | auto should be accepted as a valid value for dir - got "", expected "auto"
todo | Enumerated attributes should be case-insensitive. - got "", expected "auto"

Note You need to log in before you can comment on or make changes to this bug.