Intermittent test failure in layout/reftests/svg/smil/transform/scale-1.svg

RESOLVED FIXED in mozilla11

Status

()

Core
SVG
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: roc, Assigned: dholbert)

Tracking

({intermittent-failure})

Trunk
mozilla11
x86
Windows XP
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs landing on beta/aurora after confirmed-fixed on m-c])

Attachments

(1 attachment)

http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1306773373.1306776029.13649.gz&fulltext=1

The test failure is not visually noticeable.
Blocks: 438871
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 40

6 years ago
(In reply to comment #0)
> The test failure is not visually noticeable.

Elaborating on that slightly: At least in the latest instance, there's a single column of vertical pixels that mismatch in each of the far-right circles.  The mismatching pixels are rgb(255,214,102) in the testcase vs. rgb(255,215,102) in the reference -- that's a difference of 1 in the green channel.
(Assignee)

Updated

6 years ago
OS: Windows 7 → Windows XP
Version: unspecified → Trunk
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 95

6 years ago
Per comment 40, it looks like we're just triggering an occasional visually-undetectable rounding error with a single-pixel-position gradients.

While this might be a real bug, it's pretty minor & not at all what this test is meant to verify.  There's actually no reason we need to use a gradient here, AFAIK -- we could just as easily be scaling a plain circle.
(Assignee)

Comment 96

6 years ago
Created attachment 577186 [details] [diff] [review]
fix: use smiley instead of gradient-fill

This changes the test to use a smiley-face instead of a gradient, to hopefully avoid the randomorange, per previous comment.

The smiley-face is essentially copypasted from skew-1.svg, except that I cut most of the values in half to get it to be the right size (r=20 instead of r=40).  (one exception: I didn't cut the mouth-size in half, because I was too lazy to figure out what values to tweak and by how much -- and also, the double-size mouth actually looks fine. :) )
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Attachment #577186 - Flags: review?(birtles)
Comment on attachment 577186 [details] [diff] [review]
fix: use smiley instead of gradient-fill

Review of attachment 577186 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Thanks for fixing this Daniel!
Attachment #577186 - Flags: review?(birtles) → review+
(Assignee)

Comment 98

6 years ago
No problem, thanks for the quick r+!
Pushed to Try as a sanity-check before landing:
 https://tbpl.mozilla.org/?tree=Try&rev=7937d628cf63
Comment hidden (Treeherder Robot)
(Assignee)

Comment 100

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/619852efb27e

Assuming this really fixes the randomorange on m-c-based branches, we should land this on branches, too (since it's a test-only fix).  I'll wait a week or two before doing that, to be sure m-c-based branches like this.
Whiteboard: [orange] → [orange][needs landing on beta/aurora after confirmed-fixed on m-c]
Target Milestone: --- → mozilla11
https://hg.mozilla.org/mozilla-central/rev/619852efb27e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
https://tbpl.mozilla.org/php/getParsedLog.php?id=7815038&tree=Mozilla-Aurora
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange][needs landing on beta/aurora after confirmed-fixed on m-c] → [needs landing on beta/aurora after confirmed-fixed on m-c]
You need to log in before you can comment on or make changes to this bug.