Intermittent Tegra "restarting as root failed" followed by Timed out while waiting for server startup

RESOLVED DUPLICATE of bug 650535

Status

defect
P5
normal
RESOLVED DUPLICATE of bug 650535
8 years ago
6 years ago

People

(Reporter: philor, Assigned: bear)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [android][tegra][android_tier_1])

(Reporter)

Description

8 years ago
Could just be a slightly different looking version of bug 650535, dunno since the log's pretty opaque.

http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306786127.1306787123.25168.gz
Android Tegra 250 mozilla-central opt test reftest-1 on 2011/05/30 13:08:47 
s: tegra-054

python reftest/remotereftest.py --deviceIP 10.250.49.41 --xre-path ../hostutils/xre --utility-path ../hostutils/bin --app org.mozilla.fennec --http-port 30054 --ssl-port 31054 --pidfile /builds/tegra-054/test/../remotereftest.pid --enable-privilege --total-chunks 2 --this-chunk 1 reftest/tests/layout/reftests/reftest.list
{env}
restarting as root failed
reconnecting socket
args: ['../hostutils/bin/xpcshell', '-g', '/builds/tegra-054/test/build/hostutils/xre', '-v', '170', '-f', '/builds/tegra-054/test/build/tests/reftest/reftest/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpAYJu0E';const _SERVER_PORT = '30054'; const _SERVER_ADDR ='10.250.48.153';", '-f', '/builds/tegra-054/test/build/tests/reftest/server.js']
INFO | remotereftests.py | Server pid: 25576
uncaught exception: 2147746065
Timed out while waiting for server startup.
program finished with exit code 1
elapsedTime=96.297614
(Reporter)

Comment 1

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306821649.1306822332.30634.gz
Android Tegra 250 mozilla-central opt test mochitest-4 on 2011/05/30 23:00:49 
s: tegra-054
(Reporter)

Comment 2

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306823265.1306823881.3258.gz
Android Tegra 250 mozilla-central opt test mochitest-1 on 2011/05/30 23:27:45 
s: tegra-066

I just refiled bug 650535, while demonstrating that I haven't really been looking closely at logs for a while, didn't I?
(Reporter)

Comment 3

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306871928.1306872834.18534.gz
Android Tegra 250 mozilla-central opt test jsreftest-2 on 2011/05/31 12:58:48 
s: tegra-060
(Reporter)

Comment 4

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306876007.1306877292.5049.gz
Android Tegra 250 mozilla-central opt test crashtest on 2011/05/31 14:06:47
s: tegra-060
(Reporter)

Comment 5

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306880329.1306881146.22162.gz
Android Tegra 250 mozilla-central opt test mochitest-3 on 2011/05/31 15:18:49 
s: tegra-060

http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1306907086.1306907912.1088.gz
Android Tegra 250 mozilla-central opt test jsreftest-2 on 2011/05/31 22:44:46 
s: tegra-030
Bear, Aki - any thoughts here?
Priority: -- → P5
(Assignee)

Comment 9

8 years ago
This is another "view" of bug 650535 - the error is happening within the runtestsremote code so we should bounce this over to ateam for a debug.

Updated

8 years ago
Blocks: 661896
(Reporter)

Updated

8 years ago
Duplicate of this bug: 666356

Comment 82

8 years ago
(In reply to comment #9)
> This is another "view" of bug 650535 - the error is happening within the
> runtestsremote code so we should bounce this over to ateam for a debug.

From orangefactor, this seems to be occurring less. [1].

Bear, do you still think this is an issue we need to look into?

[1]: http://brasstacks.mozilla.com/orangefactor/?display=Bug&tree=mozilla-central&endday=2011-07-05&startday=2011-06-07&bugid=660729
(Assignee)

Comment 83

8 years ago
The underlying issue does need to be solved but this bug is not about that issue.  Either we close this and file a new one or morph this bug to track it.
(Reporter)

Comment 84

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1309963368.1309963982.6958.gz

It's probably less that it's occurring less, and more that I've stopped feeling that I have the time to diagnose every single Android failure - I can barely keep up with half the trees just starring everything I think is not code related as "infra; retriggered" without digging through every single log.
(Assignee)

Comment 85

8 years ago
I'm moving the more aggressive clearing/checking of the tegra's environment fix higher on my todo priority list - going to try and make it so that even edge cases get caught and dealt with
(Assignee)

Updated

8 years ago
Whiteboard: [orange] → [orange][android][tegra]
(Assignee)

Updated

8 years ago
Duplicate of this bug: 667280
Whiteboard: [orange][android][tegra] → [orange][android][tegra][android_tier_1]
bear, this may be a dupe of bug 650535, can you investigate?
Assignee: nobody → bear
(Assignee)

Comment 91

8 years ago
yes, this is a duplicate of 650535 as they are both symptoms of when clientproxy doesn't clean up the tegra environment foopy-side.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650535
Whiteboard: [orange][android][tegra][android_tier_1] → [android][tegra][android_tier_1]
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.