WebGL is blocked despite my NVIDIA driver seeming to meet Firefox's minimum version requirement

VERIFIED DUPLICATE of bug 653102

Status

()

VERIFIED DUPLICATE of bug 653102
7 years ago
7 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
(For background, see bug 624390, bug 624593, and bug 639842.)

WebGL is blocked on my Ubuntu Linux machine.  I have "3.3.0 NVIDIA 270.41.06", which seems to meet the purported requirement of "NVIDIA 257.21 or newer".

I just updated (Ubuntu System Settings > Hardware > Additional Drivers). Before I updated, I had "2.1.2 NVIDIA 173.14.30", and the block made sense.

I don't know what the first set of numbers (e.g. "3.3.0") represents.

Here's the full Graphics section of about:support:

        Adapter Description
        NVIDIA Corporation -- GeForce GTS 240/PCI/SSE2

        Driver Version
        3.3.0 NVIDIA 270.41.06

        WebGL Renderer
        Blocked for your graphics driver version. Try updating your graphics driver to version NVIDIA 257.21 or newer.

        GPU Accelerated Windows
        0/1. Blocked for your graphics driver version. Try updating your graphics driver to version NVIDIA 257.21 or newer.
(In reply to comment #0)
> (For background, see bug 624390, bug 624593, and bug 639842.)
> 
> WebGL is blocked on my Ubuntu Linux machine.  I have "3.3.0 NVIDIA
> 270.41.06", which seems to meet the purported requirement of "NVIDIA 257.21
> or newer".

Indeed it does.  Need to reproduce this using MOZ_GFX_SPOOF_GL_VERSION...

> 
> I just updated (Ubuntu System Settings > Hardware > Additional Drivers).
> Before I updated, I had "2.1.2 NVIDIA 173.14.30", and the block made sense.
> 
> I don't know what the first set of numbers (e.g. "3.3.0") represents.

It's the version of the OpenGL spec that your driver claims to implement. We only need 2.1 and don't parse this part of the string at all.
Reproduced using:

MOZ_GFX_SPOOF_GL_VERSION='3.3.0 NVIDIA 270.41.06' dist/bin/firefox -P test -no-remote about:support
It turns out that this string is parsed just fine --- the only problem you're hitting is that the blacklisting decision is cached and is only reevaluated once a day. Fixing this is bug 653102.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653102
(Reporter)

Comment 4

7 years ago
Created attachment 536219 [details]
full about:support info
Jesse:

Just so's I'm clear, this was your workflow, right?

- Discover WebGL is blocked on your Linux machine, whose profile was not copied from anywhere in particular (ignoring Sync).
- Update your NVIDIA driver and restart the world.
- WebGL still disabled, wtf?

Note you can force a blocklist refresh by executing this in an error console:

Components.classes["@mozilla.org/extensions/blocklist;1"].getService(Components.interfaces.nsITimerCallback).notify(null);
(Reporter)

Comment 6

7 years ago
That is exactly what happened.

WebGL works fine after clearing my gfx.blacklist prefs (suggested by bjacob on irc before I saw your comment). It also works fine in a new profile. Thanks for the quick responses!
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.