Last Comment Bug 660747 - TM: perlstress-001.js failing without tracejit or methodjit
: TM: perlstress-001.js failing without tracejit or methodjit
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Linux
: -- normal with 1 vote (vote)
: mozilla11
Assigned To: Andrew Paprocki
:
Mentors:
Depends on:
Blocks: 625600
  Show dependency treegraph
 
Reported: 2011-05-30 21:59 PDT by Chris Leary [:cdleary] (not checking bugmail)
Modified: 2012-02-01 12:45 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed


Attachments
Revert YARR begin characters optimization (19.55 KB, patch)
2011-11-21 21:23 PST, Andrew Paprocki
dmandelin: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Previous patch rebased to Aurora (19.52 KB, patch)
2011-12-17 08:37 PST, Andrew Paprocki
andrew: review+
Details | Diff | Splinter Review

Description Chris Leary [:cdleary] (not checking bugmail) 2011-05-30 21:59:03 PDT
Ubuntu 32 bit build.

 FAILED! [reported from test()] Section 180 of test - 
 FAILED! [reported from test()] regexp = /(abc|)ef/i
 FAILED! [reported from test()] string = 'ABCDEF'
 FAILED! [reported from test()] ERROR !!! regexp FAILED to match anything !!!
 FAILED! [reported from test()] Expect: EF,
 FAILED! [reported from test()] Actual: null
 FAILED! [reported from test()]  : Type mismatch, expected type string, actual type object Expected value '["HIJ"]', Actual value 'null' 

Guessing it's because it's falling back on YARR-interp.
Comment 1 David Mandelin [:dmandelin] 2011-06-29 18:30:27 PDT
This WFM now. Would you mind retesting?
Comment 2 Chris Leary [:cdleary] (not checking bugmail) 2011-07-22 15:53:30 PDT
Linux 64 dbg nmnt (no methodjit no tracejit):

 FAILED! [reported from test()] Section 83 of test - 
 FAILED! [reported from test()] regexp = /(abc|)ef/
 FAILED! [reported from test()] string = 'abcdef'
 FAILED! [reported from test()] ERROR !!! regexp FAILED to match anything !!!
 FAILED! [reported from test()] Expect: ef,
 FAILED! [reported from test()] Actual: null
 FAILED! [reported from test()]  : Type mismatch, expected type string, actual type object Expected value '["hij"]', Actual value 'null'

Linux 32 nmnt:

 FAILED! [reported from test()] Section 83 of test - 
 FAILED! [reported from test()] regexp = /(abc|)ef/
 FAILED! [reported from test()] string = 'abcdef'
 FAILED! [reported from test()] ERROR !!! regexp FAILED to match anything !!!
 FAILED! [reported from test()] Expect: ef,
 FAILED! [reported from test()] Actual: null
 FAILED! [reported from test()]  : Type mismatch, expected type string, actual type object Expected value '["hij"]', Actual value 'null'
Comment 3 Chris Leary [:cdleary] (not checking bugmail) 2011-07-22 15:53:58 PDT
Configure command used for 64b: ../js/src/configure --disable-tracejit --disable-methodjit --enable-optimize --disable-debug
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-07-22 15:57:58 PDT
But, when I run the *correct* debug settings in comment 3, I also get the same result. :-)
Comment 5 Andrew Paprocki 2011-10-10 08:20:07 PDT
I also separately hit this bug when I manually grafted the yarr upgrade patches on top of 1.8.5 standalone. (We build with yarr JIT disabled.)
Comment 6 Andrew Paprocki 2011-11-21 21:19:11 PST
I've found the issue. The upstream WebKit r87109, which was a reversion of a previous rev, was not reverted in SM. When I apply the diff for r87109 to the engine with JIT disabled this test then passes.

WebKit changeset r87109: http://trac.webkit.org/changeset/87109
WebKit bug 61306: http://bugs.webkit.org/show_bug.cgi?id=61306
Comment 7 Andrew Paprocki 2011-11-21 21:23:36 PST
Created attachment 576085 [details] [diff] [review]
Revert YARR begin characters optimization
Comment 8 Andrew Paprocki 2011-11-21 21:24:53 PST
$ ./jstests.py ../shell/js ecma_3/RegExp
[  63|   0|   5] 100% ===============================================>|   14.0s
PASS
$
Comment 9 David Mandelin [:dmandelin] 2011-11-22 14:17:55 PST
Comment on attachment 576085 [details] [diff] [review]
Revert YARR begin characters optimization

Review of attachment 576085 [details] [diff] [review]:
-----------------------------------------------------------------

Sweet! Thanks for tracking this down. If you check it in, could you please include the WebKit rev number in the checkin comment?
Comment 10 Andrew Paprocki 2011-11-22 17:12:13 PST
I'm just whiteboarding it for checkin, I don't have access to do it myself.
Comment 11 Andrew Paprocki 2011-11-22 17:15:13 PST
Comment on attachment 576085 [details] [diff] [review]
Revert YARR begin characters optimization

I also flagged approval-mozilla-aurora to see if it is possible to land this there. This has no impact on users with JIT enabled (virtually all browser users), but it impacts me and other embedders on non-JIT platforms. WebKit has had this reversion in their tree for ~5 months now, so it seems very low risk.
Comment 13 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-28 05:18:43 PST
https://hg.mozilla.org/mozilla-central/rev/ec749c25ed64
Comment 14 christian 2011-12-16 14:28:27 PST
I landed on mozilla-aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/a8affcb9442c

Note it didn't apply cleanly but the hunk that failed was merely removing a line that is no longer in the file anyway (I think!).
Comment 15 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-12-16 14:50:13 PST
(In reply to Christian Legnitto [:LegNeato] from comment #14)
> I landed on mozilla-aurora:
> 
> http://hg.mozilla.org/releases/mozilla-aurora/rev/a8affcb9442c

backed out because it was burning all builds
Comment 16 Andrew Paprocki 2011-12-17 08:37:42 PST
Created attachment 582544 [details] [diff] [review]
Previous patch rebased to Aurora

The original mozilla-inbound patch burned Aurora because:

changeset:   80723:f2fb79b0d7d2
user:        Chris Leary <cdleary@mozilla.com>
date:        Tue Nov 29 15:24:44 2011 -0800
summary:     Bug 691299: Lower maximum quantifier. (r=dmandelin, a=akeybl)

was applied to Aurora before this changeset and in mozilla-inbound this changeset was exists after this patch. I applied the patch manually and made sure mozilla-aurora builds with it applied.

Note You need to log in before you can comment on or make changes to this bug.