Last Comment Bug 660968 - Jprof doesn't build shared library
: Jprof doesn't build shared library
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- minor (vote)
: ---
Assigned To: Randell Jesup [:jesup]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 14:07 PDT by Randell Jesup [:jesup]
Modified: 2011-06-27 12:26 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Simple fix to force a shared library and fix build instructions (1.73 KB, patch)
2011-05-31 15:00 PDT, Randell Jesup [:jesup]
khuey: review+
asa: approval‑mozilla‑aurora+
rjesup: checkin+
Details | Diff | Review

Description Randell Jesup [:jesup] 2011-05-31 14:07:27 PDT
jprof doesn't build a shared library by default (it seemed to work back in April when I was developing the jprof updates, but doesn't anymore).  Force jprof to be a shared lib.

Also, the build instructions in the README.html are incorrect (missed that in the last update)
Comment 1 Randell Jesup [:jesup] 2011-05-31 15:00:10 PDT
Created attachment 536427 [details] [diff] [review]
Simple fix to force a shared library and fix build instructions

Just need to figure out who should review this (trying to be nice to bz ;-)  Also we'll need to decide if it needs to get merged into FF6
Comment 2 Randell Jesup [:jesup] 2011-06-01 01:09:02 PDT
Checked in as http://hg.mozilla.org/mozilla-central/rev/16dc1fd9c28a

Leaving open for consideration for Aurora - this is a debug-tools only patch that would be nice not to have to hand-apply to look at any perf issues in Aurora.  Not by any means critical though.  Dropping to 'minor'
Comment 3 Boris Zbarsky [:bz] 2011-06-01 05:35:34 PDT
> Leaving open for consideration for Aurora

That's tracked via the status-firefox6 and tracking-firefox6 flags on the bug and the approval flags on the patch.  Once a bug is on m-c, the status needs to change to FIXED.
Comment 4 Randell Jesup [:jesup] 2011-06-01 07:46:55 PDT
Comment on attachment 536427 [details] [diff] [review]
Simple fix to force a shared library and fix build instructions

Thanks - the status/tracking stuff is changed since 8 years ago.  :-)  

Nominating for Aurora/FireFox6.
Comment 5 Asa Dotzler [:asa] 2011-06-01 12:14:54 PDT
Comment on attachment 536427 [details] [diff] [review]
Simple fix to force a shared library and fix build instructions

NPOTB is an easy approval.
Comment 6 Randell Jesup [:jesup] 2011-06-21 21:58:25 PDT
Fix checked into Aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/736bfe524cc2

Note You need to log in before you can comment on or make changes to this bug.