NPAPI OOP Plugin System does not transmit NPPVpluginWantsAllNetworkStreams

RESOLVED FIXED

Status

()

Core
Plug-ins
--
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Thomas Harning, Assigned: Josh Aas)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox5- affected, firefox6- fixed, firefox7 affected)

Details

Attachments

(1 attachment, 1 obsolete attachment)

18.14 KB, patch
Benjamin Smedberg
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.68 Safari/534.30
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

NPPVpluginWantsAllNetworkStreams is a required item for our plugin in dealing with web service request errors since they return 500 status codes.

Visible in dom/plugins/PluginInstanceChild.cpp and dom/plugins/PluginInstanceParent.cpp is a lack of handling for this value.  The utilities parse it out and I can find log statements when running with NSPR_LOG_MODULE=all:5 that value 18 (NPPVpluginWantsAllNetworkStreams) is not handled for both NPN_SetValue and NPP_GetValue calls.

If I manually disable OOPP, the plugin works correctly.

Reproducible: Always

Steps to Reproduce:
1. Setup an NPAPI plugin that handled NPP_GetValue return returns 'true' for NPPVpluginWantsAllNetworkStreams in the correct manner (or sets it using NPN_SetValue)
2. Ensure OOPP is enabled for the NPAPI plugin in question
3. Perform a web request known to return a non-200 result with NPP_GetURLNotify or NPP_PostURLNotify


Actual Results:  
1) No callback to NPP_GetValue for NPPVpluginWantsAllNetworkStreams.
2) A URLNotify callback with failure and no additional data

Expected Results:  
1) A callback to NPP_GetValue for NPPVpluginWantsAllNetworkStreams of not set already.
2) A full web request response with headers and data


Since this issue can be resolved by blacklisting the plugin in the configuration. 

I 'can' work around this issue by setting the global MOZ_DISABLE_OOP_PLUGINS=1 or using global javascript configuration file (will need to figure out how)... however this is not desirable.

This bug strongly affects software that we are trying to deploy.
(Assignee)

Updated

6 years ago
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

6 years ago
Created attachment 536655 [details] [diff] [review]
fix v1.0

This will probably fix it but it'd be nice to have a test. I'll write one next.

Comment 2

6 years ago
Is NPPVpluginWantsAllNetworkStreams documented anywhere?
Keywords: dev-doc-needed
(Assignee)

Comment 3

6 years ago
Actually, that patch may not do anything. It looks like we query the plugin for the value when we need it and don't support having the plugin set it on the browser.
Keywords: dev-doc-needed
(Assignee)

Comment 4

6 years ago
We also don't seem to be consistent about when we request that information from the plugin. For byte range streams we check when "responseCode != 200", for other streams we do it when "responseCode > 206".
(Assignee)

Updated

6 years ago
Attachment #536655 - Attachment is obsolete: true
(Reporter)

Comment 5

6 years ago
(In reply to comment #2)
> Is NPPVpluginWantsAllNetworkStreams documented anywhere?
It is documented in the source code as a value to denote that the plugin wants all network streams, including error cases instead of throwing a network error to the plugin.

In my experience, Firefox has performed a NP_GetValue on this prior to either returning a network error or giving back all web request data (based on true/false value).  It also looks like NP_SetValue 'should' work, but I have not used it except when trying to debug this problem.
(Assignee)

Comment 6

6 years ago
Created attachment 536728 [details] [diff] [review]
fix v2.0
Attachment #536728 - Flags: review?(benjamin)

Updated

6 years ago
Attachment #536728 - Flags: review?(benjamin) → review+
(Assignee)

Comment 7

6 years ago
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/90ab2594811b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

6 years ago
This is a safe regression fix with a test. I think we should consider porting to Aurora (FF6). I'll write the patch if there is an indication that we'd take it.
status-firefox5: --- → affected
status-firefox6: --- → affected
status-firefox7: --- → affected
tracking-firefox5: --- → ?
tracking-firefox6: --- → ?

Comment 9

6 years ago
no chance for 5. release team would consider a patch for 6.
tracking-firefox5: ? → -
tracking-firefox6: ? → -
(Assignee)

Comment 10

6 years ago
Comment on attachment 536728 [details] [diff] [review]
fix v2.0

This patch works on mozilla-aurora. Requesting approval.
Attachment #536728 - Flags: approval-mozilla-aurora?

Comment 11

6 years ago
Do we know which plugins this affects? Are we blocklisting some plugins because of this?
(Reporter)

Comment 12

6 years ago
It affects a plugin for a product that is in the progress of being released.  I do not know if I can name it, if we can get put on a blacklist for 4.0 quickly, I could probably convince management to release the information to get put on the blacklist.  We are supporting Firefox 3.6 and 4.0 at the moment, of which 3.6 doesn't have a problem unless users alter the Mozilla configurations.

To workaround the issue, we are deploying a Firefox Extension registered using the HKLM\Software\Mozilla\Firefox\Extensions registry area to inject a preferences setting that blacklists our plugin DLL from OOP execution.  While this is a working fix, it is somewhat "unsightly" from the user-experience side with the user seeing a pop-up that an extension was just installed.

Comment 13

6 years ago
Josh, do we have any idea how popular this API is? I'm leaning towards saying we wait for the next uplift.
(Assignee)

Comment 14

6 years ago
I don't remember exactly who uses it but it's probably popular enough that not supporting it worries me. Given how simple this patch is and how this feature can make or break some significant plugin functionality I'm inclined to recommend that we push this to aurora.

Comment 15

6 years ago
OK, I'm leaning back in the other direction now. Thanks Josh. Any other drivers, if you'll second this, go ahead and mark it. If no one gets to this before Tuesday, we'll get it in that triage meeting.

Updated

6 years ago
Attachment #536728 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Built locally and passed mochitest 'dom/plugins' (include new testcase).

Pushed to mozilla-aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/0e97d6206a1e
status-firefox6: affected → fixed
(Reporter)

Comment 17

6 years ago
Reporting that I have found the issue as fixed in the nightly builds without the workaround that puts our extension in the set of "blacklisted from out-of-process plugins".
You need to log in before you can comment on or make changes to this bug.