Last Comment Bug 661289 - Scratchpad Save File prompts to overwrite existing files twice.
: Scratchpad Save File prompts to overwrite existing files twice.
Status: RESOLVED FIXED
[scratchpad][good-first-bugs][fixed-i...
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Pavel Cvrcek [:JasnaPaka]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-01 10:37 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-08-12 07:00 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[checked-in] Patch v1 (811 bytes, patch)
2011-08-09 14:17 PDT, Pavel Cvrcek [:JasnaPaka]
rcampbell: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-06-01 10:37:29 PDT
STR:

1. Open a Scratchpad.
2. Enter some text.
3. Select Save As from the File menu.
4. Save it as Scratchpad.js to the default location.
5. Select Save As from the File menu.
6. Save it as Scratchpad.js to the default location.

Expected results:

File dialog should prompt asking if the user wishes to replace the file.

Actual:

File dialog prompts, then another prompt appears in the scratchpad window asking if you would like to replace the file.

That is 1 too many prompts!
Comment 1 Rob Campbell [:rc] (:robcee) 2011-08-04 07:23:38 PDT
bugzilla, why do you so often get my flags wrong?
Comment 2 Pavel Cvrcek [:JasnaPaka] 2011-08-09 14:17:08 PDT
Created attachment 551884 [details] [diff] [review]
[checked-in] Patch v1

Maybe something like this?
Comment 3 Rob Campbell [:rc] (:robcee) 2011-08-10 07:25:56 PDT
Comment on attachment 551884 [details] [diff] [review]
[checked-in] Patch v1

looks like it'll do the trick! Thanks for the patch! :)
Comment 4 Rob Campbell [:rc] (:robcee) 2011-08-11 07:38:49 PDT
Comment on attachment 551884 [details] [diff] [review]
[checked-in] Patch v1

http://hg.mozilla.org/integration/fx-team/rev/4d97114b4e60
Comment 5 Rob Campbell [:rc] (:robcee) 2011-08-12 06:59:33 PDT
Comment on attachment 551884 [details] [diff] [review]
[checked-in] Patch v1

http://hg.mozilla.org/mozilla-central/rev/4d97114b4e60

Note You need to log in before you can comment on or make changes to this bug.