Last Comment Bug 661767 - History and Bookmarks search result is wrong. Searching history and bookmarks is completely useless for managing them.
: History and Bookmarks search result is wrong. Searching history and bookmarks...
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: Firefox 8
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 658242
Blocks: 630225
  Show dependency treegraph
 
Reported: 2011-06-03 00:59 PDT by Alice0775 White
Modified: 2011-07-26 16:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Search result in the Library (159.35 KB, image/png)
2011-06-03 00:59 PDT, Alice0775 White
no flags Details

Description Alice0775 White 2011-06-03 00:59:16 PDT
Created attachment 537099 [details]
Search result in the Library

Build Identifier: 
http://hg.mozilla.org/releases/mozilla-aurora/rev/436da90e737a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.2) Gecko/20110508 Firefox/6.0a2 ID:20110602042006
http://hg.mozilla.org/mozilla-central/rev/9a6c139a4e58
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110602 Firefox/7.0a1 ID:20110602030726

History and Bookmarks search result is wrong.
Searching history and bookmarks is completely useless for managing them.

Reproducible: Always

Steps to Reproduce:
1. Open Library
2. Search https://bugzilla --only 3 items found in my case --it is _wrong_.

3. Search bugzilla --8655 items found in my case --It is correct perhaps.


Actual Results:  
History and Bookmarks search result is wrong.
Number of result is completely wrong.

Expected Results:  
Search of history and Bookmarks should be performed properly.

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/2e5e4197b9db
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110418 Firefox/6.0a1 ID:20110418013520
Fails:
http://hg.mozilla.org/mozilla-central/rev/202537779786
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110418 Firefox/6.0a1 ID:20110418054324
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2e5e4197b9db&tochange=202537779786
Suspencted Bug:
24f177c8b6f6	Marco Bonardo — Bug 630225 - Expose frecency as a sorting order for the history sidebar (with slight query builder optimization). r=dietrich
Comment 1 Marco Bonardo [::mak] 2011-06-06 13:28:05 PDT
I suspect that's because the search strips http and https from the url before starting the search.
The reason is practically the same as bug 658242, since now the locationbar and the search box share the same code, they have the same behavior.

We should figure out a non-breaking (add-ons) way of matching like the old search, we could maybe add a MATCH_ANYWHERE_PLAIN behavior that won't do any magic filtering or normalization.
Comment 2 Marco Bonardo [::mak] 2011-07-26 16:52:22 PDT
should have been fixed by the patch in bug 658242

Note You need to log in before you can comment on or make changes to this bug.