Last Comment Bug 661869 - Consider including Segoe UI in the list of typefaces that fall back to GDI classic
: Consider including Segoe UI in the list of typefaces that fall back to GDI cl...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 2 votes (vote)
: ---
Assigned To: Kai Liu
:
:
Mentors:
Depends on: 661471 668162
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-03 10:12 PDT by Kai Liu
Modified: 2011-06-29 02:06 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
add Segoe UI to force_gdi_classic_for_families (1.15 KB, patch)
2011-06-03 10:12 PDT, Kai Liu
jfkthame: review+
asa: approval‑mozilla‑aurora-
Details | Diff | Splinter Review

Description Kai Liu 2011-06-03 10:12:33 PDT
Created attachment 537174 [details] [diff] [review]
add Segoe UI to force_gdi_classic_for_families

Segoe UI is the default UI typeface in non-classic Windows Vista and 7, and as such, it extensively used the browser's UI.

I think Segoe UI should be rendered in the GDI classic mode because, (1) as a UI font, a sharper contrast is probably more important than typeface fidelity, and (2) with the Start Menu, taskbar, title bars, and other prominent UI elements in Windows using GDI-style Segoe UI, Firefox's natural-style Segoe UI looks somewhat out of place in the juxtaposition.  And FWIW, IE9's UI remains GDI-rendered as well.
Comment 1 DB Cooper 2011-06-03 10:40:37 PDT
I strongly agree - the 1st thing I changed in today's nightly was to add Segoe UI to the GDI-style rendered list of fonts. Makes the UI clearer, giving equivalent quality to IE9 and Chrome.

Eliminating the "rainbow-ing" effect is a major plus.
Comment 2 Jonathan Kew (:jfkthame) 2011-06-04 00:29:41 PDT
Comment on attachment 537174 [details] [diff] [review]
add Segoe UI to force_gdi_classic_for_families

(Stealing review from jdaggett) - yes, it makes sense to include the UI font.
Comment 3 Jonathan Kew (:jfkthame) 2011-06-04 00:40:25 PDT
Pushed to trunk, hoping to make it into today's Nightly build:

http://hg.mozilla.org/mozilla-central/rev/f61efd0d321c
Comment 4 Jonathan Kew (:jfkthame) 2011-06-16 09:53:28 PDT
Comment on attachment 537174 [details] [diff] [review]
add Segoe UI to force_gdi_classic_for_families

Assuming we take bug 661471 on aurora, we should take this followup with it for consistency between the channels (and to make the Firefox UI rendering more consistent with the rest of the platform).
Comment 5 christian 2011-06-16 15:00:09 PDT
Waiting on bug 661471 aurora decision before deciding on this one.
Comment 6 Asa Dotzler [:asa] 2011-06-23 15:04:49 PDT
Comment on attachment 537174 [details] [diff] [review]
add Segoe UI to force_gdi_classic_for_families

we minused this one's dependency.

Note You need to log in before you can comment on or make changes to this bug.