Closed Bug 661950 Opened 10 years ago Closed 10 years ago

CSS @media query changing column count on window resize resets video objects

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 90268

People

(Reporter: bugzilla.mozilla.org-6h11, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110603 Firefox/7.0a1

Video objects are reset when the column count changes.

Reproducible: Always

Steps to Reproduce:
1. Install Flash
2. Go to http://www.qxm.de/gestaltung/2568/the-force (YouTube) or http://www.qxm.de/gestaltung/2604/street-level-royal-wedding (Vimeo)
3. Play video
4. Resize window to more or less than 1560 pixels width so the @media query changes column count

Actual Results:  
Video stops (YouTube) or starts over (Vimeo)

Expected Results:  
Video should continue playback
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
Changing column-count causes a reframe (regeneration of that part of the frame tree, also known as the rendering tree or box tree).  Plugins currently (see duplicate) store much of their data in the frame tree rather than the content tree, and therefore get recreated by such an operation.
You need to log in before you can comment on or make changes to this bug.