Closed Bug 661981 Opened 11 years ago Closed 11 years ago

mochitest seems to not be honoring closeWhenDone attribute when running tests

Categories

(Testing :: Mochitest, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 508664

People

(Reporter: imelven, Unassigned)

Details

i'm trying to run the CSP tests using 

TEST_PATH=content/base/test/test_CSP.html make -C ${OBJDIR} mochitest-plain

the tests run fine, and i see closeWhenDone=1 in the address bar 
(http://mochi.test:8888/tests/content/base/test/test_CSP.html?autorun=1&closeWhenDone=1&logFile=c%3A\Users\imelven\Documents\src\mozilla\ff-dbg\mochitest-plain.log&fileLevel=INFO&consoleLevel=INFO)

the browser doesn't close, even after waiting several minutes after the test html page says they all passed...  when i close the browser manually, the tests move on to the next suite
Component: Build Config → Mochitest
Product: Core → Testing
QA Contact: build-config → mochitest
This is because when you set TEST_PATH to an individual test (instead of a directory), it doesn't load the harness, only the individual test.
That's exactly right. There's a patch in bug 508664 for this, but it never got finished.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508664
You need to log in before you can comment on or make changes to this bug.