Last Comment Bug 661998 - Intermittent test_auth_proxy.js command timed out: 1200 seconds without output, attempting to kill
: Intermittent test_auth_proxy.js command timed out: 1200 seconds without outpu...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Mac OS X
-- normal (vote)
: mozilla7
Assigned To: Josh Matthews [:jdm]
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks: 438871 nsITimer-fail
  Show dependency treegraph
 
Reported: 2011-06-03 19:49 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
probable fix (1.11 KB, patch)
2011-06-05 14:18 PDT, Phil Ringnalda (:philor)
ehsan: review-
Details | Diff | Splinter Review
Fix risky use of nsITimer in xpcshell test. (1.60 KB, patch)
2011-06-07 01:47 PDT, Josh Matthews [:jdm]
gavin.sharp: review+
Details | Diff | Splinter Review

Description User image Phil Ringnalda (:philor) 2011-06-03 19:49:04 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307137450.1307139447.4584.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test xpcshell on 2011/06/03 14:44:10
s: talos-r3-leopard-053

TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_auth_proxy.js | running test ...

command timed out: 1200 seconds without output, attempting to kill
process killed by signal 9
program finished with exit code -1
elapsedTime=1590.522201
Comment 2 User image Phil Ringnalda (:philor) 2011-06-05 14:18:34 PDT
Created attachment 537478 [details] [diff] [review]
probable fix
Comment 3 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-06 06:26:04 PDT
Comment on attachment 537478 [details] [diff] [review]
probable fix

It looks like it's still possible for the timers to step over each other (e.g. if runLater is called multiple times in succession, followed by a GC before the initial timer fires). Probably less likely to be problematic than the current setup, but this would be more robust if it was converted to use executeSoon.
Comment 4 User image :Ehsan Akhgari 2011-06-06 16:53:57 PDT
Comment on attachment 537478 [details] [diff] [review]
probable fix

Gavin is right.  But AFAIK, we don't have executeSoon available in xpcshell based tests.  A simple workaround would be to use a global array to hold the timers, and instead of assigning to |timer|, appending the timers to that array.
Comment 5 User image Josh Matthews [:jdm] 2011-06-06 18:31:16 PDT
xpcshell has do_execute_soon.
Comment 6 User image :Ehsan Akhgari 2011-06-06 18:56:08 PDT
(In reply to comment #5)
> xpcshell has do_execute_soon.

Josh, was that an indication that you volunteered to take this?  :)
Comment 7 User image Josh Matthews [:jdm] 2011-06-06 19:00:24 PDT
Might as well make it official.
Comment 8 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-06 19:56:54 PDT
even if that helper didn't exist, implementing executeSoon really isn't difficult :)
Comment 9 User image Masayuki Nakano [:masayuki] 2011-06-07 00:38:07 PDT
WinOpt:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307426263.1307429669.3720.gz

> TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\netwerk\test\unit\test_auth_proxy.js | running test ...
> 
> command timed out: 1200 seconds without output, killing pid 1252
> program finished with exit code 1
> elapsedTime=2919.380000
Comment 10 User image Josh Matthews [:jdm] 2011-06-07 01:47:50 PDT
Created attachment 537754 [details] [diff] [review]
Fix risky use of nsITimer in xpcshell test.
Comment 11 User image :Ehsan Akhgari 2011-06-07 15:08:58 PDT
Pushed to cedar.

Note You need to log in before you can comment on or make changes to this bug.