The default bug view has changed. See this FAQ.

Remove XPC_IDISPATCH_SUPPORT

RESOLVED FIXED in mozilla7

Status

()

Core
XPConnect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Matheus Kerschbaum, Assigned: Matheus Kerschbaum)

Tracking

({dev-doc-complete})

Trunk
mozilla7
dev-doc-complete
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110603 Firefox/7.0a1
Build Identifier: 

Obsolete API that only serves to support the soon to be removed ActiveX embedding API.

Reproducible: Always
(Assignee)

Updated

6 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

6 years ago
Created attachment 537292 [details] [diff] [review]
part 1: Remove interfaces and tests
Attachment #537292 - Flags: review?(mrbkap)
(Assignee)

Comment 2

6 years ago
Created attachment 537294 [details] [diff] [review]
part 2: Remove XPC_IDISPATCH_SUPPORT from the build-system and XPConnect
Attachment #537294 - Flags: review?(mrbkap)
(Assignee)

Updated

6 years ago
Blocks: 662023
Assignee: nobody → matjk7
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

6 years ago
Attachment #537292 - Flags: review?(mrbkap) → review+
Comment on attachment 537294 [details] [diff] [review]
part 2: Remove XPC_IDISPATCH_SUPPORT from the build-system and XPConnect

Review of attachment 537294 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/xpconnect/src/xpcinlines.h
@@ +270,5 @@
>  
>  inline JSBool
>  XPCCallContext::HasInterfaceAndMember() const
>  {
> +    return mState >= HAVE_NAME && mInterface && (mMember);

Nitpick: no need for the parens around mMember here.

::: js/src/xpconnect/src/xpcthrower.cpp
@@ +183,2 @@
>          {
>              id = ccx.GetMember()->GetName();

This can become |jsid id = ccx.GetMember()->GetName();| now.

::: js/src/xpconnect/src/xpcwrappednative.cpp
@@ +360,1 @@
>          identity = helper.GetCanonical();

Combine these two lines into one.

@@ +825,1 @@
>              identity = do_QueryInterface(Object);

Ditto.
Attachment #537294 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 4

6 years ago
Created attachment 539001 [details] [diff] [review]
part 2: Remove XPC_IDISPATCH_SUPPORT from the build-system and XPConnect

Updated per review comments.
Attachment #537294 - Attachment is obsolete: true
Attachment #539001 - Flags: review+
Attachment #539001 - Flags: checkin?
(Assignee)

Updated

6 years ago
Attachment #537292 - Flags: checkin?
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/d115405d4e0b
http://hg.mozilla.org/mozilla-central/rev/65936325f47f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla7
The push broke the build, so I backed out all of its changesets (although I highly suspect that this bug was the culprit).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308024044.1308025082.27561.gz#err0

/builds/slave/cen-osx64/build/js/src/xpconnect/src/xpcthrower.cpp:183: warning: unused variable 'id'
/builds/slave/cen-osx64/build/js/src/xpconnect/src/xpcthrower.cpp:186: error: 'id' was not declared in this scope

In this hunk:
https://bugzilla.mozilla.org/attachment.cgi?id=539001&action=diff#a/js/src/xpconnect/src/xpcthrower.cpp_sec1

Caused by the braces around:
| jsid id = ccx.GetMember()->GetName(); |


Anyway, good riddance to ActiveX! :-)
(Assignee)

Comment 8

6 years ago
Created attachment 539322 [details] [diff] [review]
part 2: Remove XPC_IDISPATCH_SUPPORT from the build-system and XPConnect

Thanks for noticing my mistake Ed, and sorry for breaking the tree!

I pushed this updated patch to try (http://tbpl.mozilla.org/?tree=Try&rev=0c4e143610a7) to make sure everything is ok, but the build is failing with some really bizarre errors (http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/matjk7@gmail.com-0c4e143610a7/try-linux64/try-linux64-build525.txt.gz).

Am I doing something stupid or is the buildbot just screwing with me?
Attachment #539001 - Attachment is obsolete: true
Attachment #539001 - Flags: checkin?
Attachment #539322 - Flags: review+
Attachment #539322 - Flags: checkin?
(Assignee)

Comment 9

6 years ago
Try was ok with this when I pushed again, so setting checkin-needed.
Keywords: checkin-needed
(Assignee)

Updated

6 years ago
Status: REOPENED → ASSIGNED
Target Milestone: mozilla7 → ---
(Assignee)

Updated

6 years ago
Flags: in-testsuite-
(Assignee)

Comment 10

6 years ago
Created attachment 540949 [details] [diff] [review]
part 2: Remove XPC_IDISPATCH_SUPPORT from the build-system and XPConnect

Updated to tip.
Attachment #539322 - Attachment is obsolete: true
Attachment #539322 - Flags: checkin?
Attachment #540949 - Flags: review+
Attachment #540949 - Flags: checkin?
Landed on inbound.
Keywords: checkin-needed
Pushed:
http://hg.mozilla.org/mozilla-central/rev/64ff58414b5a
http://hg.mozilla.org/mozilla-central/rev/b0507816cb5e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla7
(Assignee)

Updated

6 years ago
Keywords: dev-doc-needed

Updated

6 years ago
Keywords: dev-doc-needed → dev-doc-complete

Updated

6 years ago
Attachment #537292 - Flags: checkin? → checkin+

Updated

6 years ago
Attachment #540949 - Flags: checkin? → checkin+
You need to log in before you can comment on or make changes to this bug.