-moz-animation shorthand does not accept "0" as delay value, requires "0s"

VERIFIED DUPLICATE of bug 653999

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 653999
6 years ago
3 years ago

People

(Reporter: marcoos, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 537464 [details]
Simple testcase for this bug

The -moz-animation shorthand does not accept the unitless 0 as value for delay, it requires "0s". If you ommit the "s", the rule can't be parsed:

This works:
-moz-animation: pulse 3s ease-out 0s infinite normal;

This doesn't:
-moz-animation: pulse 3s ease-out 0 infinite normal;

Since "0" is a valid value for the delay (http://www.w3.org/TR/css3-animations/#the-animation-delay-property-), it should also be accepted in the shorthand.
(Reporter)

Comment 1

6 years ago
Also, "none" is accepted as the delay value, but it's nowhere in the spec.
(Reporter)

Comment 2

6 years ago
If you open the testcase in a Webkit browser, it will animate all the three divs. Firefox only animates the first one and the third.
(Reporter)

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653999
(Reporter)

Comment 4

6 years ago
v.
Status: RESOLVED → VERIFIED
> Since "0" is a valid value for the delay (http://www.w3.org/TR/css3-animations/#the-animation-delay-property-)

That draft is just wrong.  See http://lists.w3.org/Archives/Public/www-style/2011May/0002.html
> Also, "none" is accepted as the delay value,

No, it's not.  Your shorthand using "none" is:

  animation: pulse 3s ease-out none infinite normal;

And this is being parsed as:

  animation-name: pulse;
  animation-duration: 3s;
  animation-timing-function: ease-out;
  animation-fill-mode: none;
  animation-iteration-count: infinite;
  animation-direction: normal;

with no animation-delay specified at all.

Note also that you're looking at a very out-of-date draft that doesn't even mention animation-fill-mode; the current draft of animations is at http://dev.w3.org/csswg/css3-animations/
You need to log in before you can comment on or make changes to this bug.