Restart developer-stage9.mozilla.org

RESOLVED DUPLICATE of bug 661370

Status

--
critical
RESOLVED DUPLICATE of bug 661370
8 years ago
4 years ago

People

(Reporter: sheppy, Assigned: nmaul)

Tracking

Details

(Reporter)

Description

8 years ago
We need the wiki restarted on the developer-stage9 server; it's not responding at the moment.

Comment 1

8 years ago
stage9 has been very unstable and sluggish for a couple of days now.  it would be great if IT can investigate and see if we can figure out what happened.

let's hope a restart helps... but if it doesn't, there might be other stuff going on after the mindtouch v10 upgrade. :-(
(Reporter)

Comment 2

8 years ago
It's hypothetically possible this is related to the tests I'm doing of the wiki importer tool, but realistically, it's only affecting one file or article at a time (albeit a lot of them one after another), so that seems fairly unlikely. There shouldn't be that much going on at any given moment.
Looks like both servers that serve this staging site are in a high load because of this process:

 7365 dekiwiki  18   0 1439m 711m 1676 S 198.1 70.4  30:30.63 mono.bin

I will kick now dekiwiki, but indeed, this has been going on the whole weekend.
(Reporter)

Comment 4

8 years ago
That's so weird. This should not be loading things that much.
restarted services on sm-devmostage{01,02}:

[root@sm-devmostage01 ~]# service dekiwiki status
dekiwiki is running: 31584
[root@sm-devmostage01 ~]# service dekiwiki9 status
dekiwiki9                        RUNNING    pid 31644, uptime 0:34:54

[root@sm-devmostage02 ~]# service dekiwiki status
dekiwiki is running: 11519
[root@sm-devmostage02 ~]# service dekiwiki9 status
dekiwiki9                        RUNNING    pid 9071, uptime 1:36:25
Assignee: server-ops → ashish
Status: NEW → ASSIGNED
As Dumitru pointed, it does look like dekiwiki is taking up all the memory on the host causing it to swap and jack up load on them, resulting in slow loads/unresponsiveness for brief periods of time.
reassigning to Jake, will ask him to investigate when he gets in.
Assignee: ashish → nmaul
Status: ASSIGNED → NEW
(Assignee)

Comment 8

8 years ago
Now that the restart part of the bug is complete (by the way, I just restarted it again), I'm going to mark this as a duplicate of bug 661370, where we're investigating the load issue itself.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661370
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.