Last Comment Bug 662288 - Implement CSS3 unicode-bidi: plaintext
: Implement CSS3 unicode-bidi: plaintext
Status: RESOLVED FIXED
: dev-doc-complete, rtl
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Simon Montagu :smontagu
:
Mentors:
http://dev.w3.org/csswg/css3-writing-...
Depends on: 613149
Blocks: DirAuto
  Show dependency treegraph
 
Reported: 2011-06-06 09:01 PDT by Simon Montagu :smontagu
Modified: 2012-10-13 10:10 PDT (History)
8 users (show)
smontagu: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (20.33 KB, patch)
2011-08-30 07:42 PDT, Simon Montagu :smontagu
no flags Details | Diff | Review
Patch v.2 (20.59 KB, patch)
2011-08-30 15:27 PDT, Simon Montagu :smontagu
roc: review+
Details | Diff | Review

Description Simon Montagu :smontagu 2011-06-06 09:01:18 PDT
See also bug 613149
Comment 1 Ahmed Soliman 2011-08-11 08:09:06 PDT
+1 to the priority of this, I would love to see this implemented so that we can have 613149 fixed
Comment 2 Simon Montagu :smontagu 2011-08-30 07:42:46 PDT
Created attachment 556835 [details] [diff] [review]
Patch
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-08-30 12:01:09 PDT
Comment on attachment 556835 [details] [diff] [review]
Patch

Review of attachment 556835 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/generic/nsBlockFrame.cpp
@@ +3567,5 @@
> +  // frame, because the block frame could be split by hard line breaks into
> +  // multiple paragraphs with different base direction
> +  FramePropertyTable *propTable = aState.mPresContext->PropertyTable();
> +  PRUint8 direction = PRUint32(propTable->Get(aLine->mFirstChild,
> +                                              BaseLevelProperty())) & 1;

Can we store this direction in a state bit so we don't have to do a mildly-expensive property get here?

Or condition this on bidi being enabled?
Comment 4 Simon Montagu :smontagu 2011-08-30 15:27:36 PDT
Created attachment 557016 [details] [diff] [review]
Patch v.2

Howzabouts if we move the test on unicode-bidi: plaintext out of BeginLineReflow to the callers, like so?
Comment 6 Marco Bonardo [::mak] 2011-10-19 03:07:06 PDT
https://hg.mozilla.org/mozilla-central/rev/388df914497e

Note You need to log in before you can comment on or make changes to this bug.