Last Comment Bug 662358 - Implement mingw variant of nsXPTCStubBase::StubXX directly in assembly
: Implement mingw variant of nsXPTCStubBase::StubXX directly in assembly
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla10
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 13:10 PDT by Jacek Caban
Modified: 2011-10-28 04:41 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (3.39 KB, patch)
2011-06-06 13:10 PDT, Jacek Caban
benjamin: review+
Details | Diff | Splinter Review

Description Jacek Caban 2011-06-06 13:10:56 PDT
Created attachment 537616 [details] [diff] [review]
fix v1.0

GCC doesn't support __declspec(naked) for x86, so the current code depends on how GCC decides to compile it. It worked good so far, but since GCC 4.6.0 it causes crashes on optimized builds. I've rewritten it directly in assembly, just like other GCC targets do.
Comment 1 Jacek Caban 2011-08-23 08:48:34 PDT
timeless, ping
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-10-26 09:41:42 PDT
Comment on attachment 537616 [details] [diff] [review]
fix v1.0

As mingw-only I'll rubberstamp this: I haven't actually reviewed it but I don't think it's necessary for port-specific code.
Comment 3 Jacek Caban 2011-10-27 04:36:26 PDT
Thanks, pushed to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/10e47df463b9
Comment 4 Ed Morley [:emorley] 2011-10-28 04:41:27 PDT
https://hg.mozilla.org/mozilla-central/rev/10e47df463b9

Note You need to log in before you can comment on or make changes to this bug.