Nike.com shows mobile page for 6.0X builds of Firefox

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Whiteboard: [Input], URL)

(Reporter)

Description

7 years ago
Steps to Reproduce:
1. Use the following user agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110605 Firefox/6.0a2 (or just open an Aurora build)
2. Go to www.nike.com

Actual Results:
The mobile site loads

Expected Results:
The desktop site should load.

Comment 1

7 years ago
Based on feedback on input, it looks like this also happens for Firefox 5.

Comment 2

7 years ago
I'll find a contact at Nike.  Seems this is on their side?
(Reporter)

Comment 3

7 years ago
Yeah, they're most likely not sniffing for our user agent strings. Though, it's been almost half a year. Just checked on my birch branch nightly build and its not working for me. Though, can someone check on beta and major release builds to see what happens there?

Comment 4

7 years ago
Hmm, looks like this might be fixed? Just tried visiting on Aurora from Germany and at least got to the main *choose your language* site, not the Mobile one.
It still happens. Firefox 9.0 gives a language chooser with a dark background and animations. After choosing English and USA, it gives a website with Flash.

With Firefox 10.0 or more, it gives a "mobile" language chooser.

Adding to the uafx10 bug
Blocks: 690287
Bret, did you find a contact as you mentioned in comment 2?
E-mail sent (tracking id is #120218-000091 )
Do we have any progress on this item?
WFM in Aurora 18.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.