Last Comment Bug 662390 - Define a preprocessor var for e10s compatibilty
: Define a preprocessor var for e10s compatibilty
Status: RESOLVED FIXED
[e10s]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: mozilla8
Assigned To: :Felipe Gomes (needinfo me!)
:
Mentors:
Depends on:
Blocks: 663042
  Show dependency treegraph
 
Reported: 2011-06-06 14:34 PDT by :Felipe Gomes (needinfo me!)
Modified: 2011-07-08 13:10 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.02 KB, patch)
2011-06-06 14:34 PDT, :Felipe Gomes (needinfo me!)
benjamin: review+
Details | Diff | Review

Description :Felipe Gomes (needinfo me!) 2011-06-06 14:34:01 PDT
Created attachment 537646 [details] [diff] [review]
Patch

Temporary preprocessor variable to be used to switch code and produce a e10s compatible build.

I think I found a middle-ground with the naming for the negative logic.. example usage would be:

#ifdef E10S_COMPAT
 // XXX todo AeroPeek throws on startup, bug NNNNNN 
#else
  if (Win7Features)
    Win7Features.onOpenWindow();
#endif

Ultimately some of these conditions will become runtime checks, and some others will just disappear.. this var will be removed at some point
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-06-07 08:36:40 PDT
Just to clarify, this is a transition step to get Firefox-on-e10s working? You'll be building with --enable-e10s-compat, which will disable bits of code that don't currently work, until you get everything working, at which point you'll remove this option and the ifdefs?

If that's correct, can you file a follow-up bug to track the removal? (presumably it can depend on the Firefox e10s tracking bug) Also, mention that bug number in a comment above the option in configure.in.
Comment 2 :Felipe Gomes (needinfo me!) 2011-06-07 14:00:00 PDT
That's precisely it, Ted. Filed bug 662601 and mentioned it in the comment

Landed in e10s:
http://hg.mozilla.org/projects/electrolysis/rev/c68fab138909
Comment 3 Marco Bonardo [::mak] 2011-07-01 07:47:19 PDT
I backed out everything from central since Android and Maemo were unhappy about the push these changes were part of.
Comment 4 :Felipe Gomes (needinfo me!) 2011-07-08 13:10:16 PDT
http://hg.mozilla.org/mozilla-central/rev/20fb4a801fee

Note You need to log in before you can comment on or make changes to this bug.